Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Dataflow Error: Access token has expired resubmit with a new access token

I'm trying to create a transformation dataflow from a staging dataflow. 
The staging dataflow contains a big volume of data and refreshes fine.
In the transformation dataflow I'm trying to group and aggregate the staging dataflow.
I'm getting this error after an hour or so:

[DM_ErrorDetailNameCode_UnderlyingErrorMessage]=<ccon>Access token has expired resubmit with a new access token</ccon> [DM_ErrorDetailNameCode_UnderlyingHResult]=-2147467259 [Microsoft.Data.Mashup.ValueError.Error]=error "Microsoft.Mashup.Engine1.Runtime.ValueException: [Expression.Error] The field 'pbi.error' of the record wasn't found.#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.CreateValueForThrow(IThrowExpression throwExpr)#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.<>c__DisplayClass23_0.<CreateValueForRecord>b__0(Int32 index)#(cr)#(lf) at Microsoft.Mashup.Engine1.Runtime.RecordValue.DemandRecordValue.get_Item(Int32 index)#(cr)#(lf) at Microsoft.Data.Mashup.ProviderCommon.MashupResource.TryGetValue(Func`1 getValue IValue& value String& errorMessage)#(cr)#(lf)Record" [Microsoft.Data.Mashup.ValueError.Reason]=TokenExpired

How can I solve this?
Thanks.

Status: Investigating

Hi @gp10 ,

 

We've found feedback from other users who have had similar experiences to yours. Here are some suggestions from the PG team Please see if this mitigates your problem.

"Customer appears to be using Feb 2023 version of the gateway. Can you please ask the customer to upgrade gateway to the latest version and re-capture gateway logs? There were some changes in the token refresh implementation in Jan 2023, upgrading will assure we have the latest version being used. Also ensure only one version of the gateway is installed.

 

Customer should also consider removing all existing credentials to the dataflow and recreating them. Sometimes that can fix authentication problems in PBI service."

 

Best regards.
Community Support Team_ Caitlyn

Comments
egnvictorfarias
New Member
  Hi, I managed to solve it! 

Despite appearing online, it wasn't working: the problem started after I was 'forced' to change my office365 password, I edited the 2 Gateways and confirmed my credentials.

egnvictorfarias_0-1703615082424.png

 

egnvictorfarias_1-1703615105472.png

 

I just clicked edit and confirmed the credentials. Then I tried refreshing the dataset and it worked.
This must be done for each gateway that has credentials (file/folder/etc)

 

feadrian
Regular Visitor

I have the same problem, but...

- It happens on Datasets that are using Dataflows
- It happens when my company forces me to update mi Windows sign-on password

It happens as if those Datasets had the old password embedded instead of a one-time validation to access the dataflow, independent of latter changes

 

The problem is I don't know hoy to solve it
I even tried updating the pbix after refreshing in desktop and still, refresh gives the same error