Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Data refresh through PBI Gateway keep prompting credential missing incorrectly

While using PBI Service with on-premise data gateway connecting local excel files, the refresh keeps failed with "credentialMissing" error, however all credentials has already been given and verified (with a green tick next to the each data source shown under gateway connection), nothing can do......



Status: New
Regular Visitor

I am having exactly the same problem, with the same error code -2147467259 and error message. I also have a full list of green ticks. The report had been successfully going through the scheduled refresh until I made some minor changes to it on Saturday morning. I have run some simple test versions, and the stage that seems to create the problem is any merge involving Excel or csv files, despite them being within the common folder used for the on-premises gateway. Without such merges, all of the data will refresh. I have another report with some of the same data and merges that has not been amended since 6 August, and that is continuing to refresh successfully. Is is something to do with the August update of Power BI?

Regular Visitor

I am also facing the same issue. The dataset was refreshing fine till 13th August. Since 14th August it started failing.

Not applicable

Same issue here.  Thought it might gateway version out-of-date, but updated to latest version yesterday and still the same errors.   Wierd thing is it is not consistent.  We have multiple file sources being pulled from a "folder" and is is different files that will fail each time.  

Advocate I

Currently using DAX UNION function as a workaround

Advocate I

We are having the same issue since the August desktop upgrade.  When we refresh in desktop and publish to the service any report with append or merge step in them which also points to two excel files in the same folder, we get this error.  If we move one of the excel files to a different folder we do not get the error.

Not applicable

We are having exactly same issue, since I made changes to the Power BI Desktop files from Monday 24/08/2020 onwards, I made changes to files on Saturday 23/08/2020 and it was all good updating on the service. I did a lot of testing like:


  1. Change the file name and upload on Service - Fail.
  2. Upload on another workspace - Fail.
  3. Upload from another user - Fail.
  4. Update to latest August Power BI software (2.84.861.0 64-bit) and upload - Fail.
  5. Extra a previous version of the Power BI desktop file which is 23/08/2020 or prior and upload - Success.
  6. Use the 23/08/2020 or prior desktop version file, upload on service and then make visual changes on the service and save it - Success.

We extracted the previous version files from 23/08/2020 or prior depnding on when was last saved (4 Power BI reports which we have made changes yesterday 24/08/2020) and upload them on to the service and make the visual changes directly and it is fine for now.  But the big problem is I cannot add any new data source or make any visual changes on the desktop file, as soon as I make changes on desktop file and upload on the server it fails to refresh.


I logged a Microsoft Support Ticket yesterday 24/08/2020 and a support enginner got in touch with me and we screen shared the issue, we are going to have a meeting with the Microsoft engineer in an hour again and will see what they have to say about it.


Will keep you guys posted, I have also asked the engineer to take a look at this post and told him that it's just not me there are other who have the same issue.

Advocate I

Yes, please let us know what Microsoft says!  Thanks, Mia.

Not applicable

Alright, I had a second session with the Microsoft Engineer and he said that there is some issue with folder data source.  We performed a test on our files:


  1. Picked a Power BI report which was failing.
  2. Replaced the folder data source to single *.csv or *.txt or *.xlsx (Engineer said this is just a workaround for now to temporarily fix our problem, please note this is not ideal when you have 100's of files you need to pick up from a folder e.g Daily Uber trip files).
  3. Once I changed the folder to single *.csv or *.txt or *.xlsx source and upload on the server the refresh started working properly.
  4. Now this is not an ideal solution for us, out of the 4 Power BI report which were failing I changed 2 of them to non folder data source and fixed it for the time being the remaining 2 are still a problem.

Microsoft Engineer did mention that they are aware of this issue and working on it right now.  Apparently they have 3 teams working on issue, Desktop Team, Gateway Team, Service Team.  Once they figure out where the problem is then they start working on the fix.


I will keep you guys posted on this issue once I get further info.  I am not sure if you have same issue as mine as other users in this community has SQL and other data source, but for my issues the Engineer knew that folder source is creating the problem.

Not applicable

@sunnyleung  and @mlucking as explained in my earlier post, @sunnyleung  I can see that you have folder data source, change that to just excel or csv and give it a try if that temporarily solves your problem?

Advocate I

@Anonymous thanks for the update.  We will see if that solution helps any of our issues!