Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Cannot compute tables in PPU Workspace, new failure on existing dataflow

I have been working on a series of ETL dataflows in a PPU workspace. The source is a cloud SQL server concted through an on premises gateway. Until yesterday I did not have any issues with computed entities; today I tried to edit one and got the error "Computed tables require Premium to refresh. To enable refresh, upgrade this workspace to Premium capacity, or remove this table." I asked for the gateway server to be rebooted and this did not resolve the issue. I created a new PPU workspace, added a new dataflow sourced to the same gateway connection with 2 tables, saved, refreshed, then tried to merge and get the same error; I tried with an onsite SQL server connected through the gateway, and get the same error. I tried connecting to the onsite SQL server without the gateway (Create new connection) and got an "Unexpected error (Session ID: 30ed5e9f-2b87-4954-a402-f69d5e203921, Region: us)". In the meantime, the original dataflows that have scheduled refreshes that include computed entities are working fine. I checked with IT and our only change control since that time was network resiliency / failover testing. 

Status: Delivered

The fix is deployed.

Community Support
Status changed to: Delivered

The fix is deployed.