Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Calculated column works in Power BI desktop but not Power BI service. Visual won't load.

I have a pie chart visual in my report that uses a calculated column as one of the fields. Up until now it stopped working in Power BI service. Nothing has changed on the report and it has always worked in the past. The visual works fine in Power BI desktop but when published to Service it gives me an error. Any ideas why it would stop working suddenly?

 

chang_B_0-1676468657256.png

 

Status: Accepted

Hi @chang_B 

It’s a known issue . The engineers are actively working on this issue and I will come back with an update if there is any progress.

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
AShadow
New Member

We are in the same boat, and are unable to change storage modes. We need this bug fixed. 

chang_B
Advocate I

@v-yetao1-msft  Can we please get an update on this? Many users are experiencing the same issue which I believe something changed in Power BI.

RLundahl
New Member

I don't understand why we have to Vote on bugs the MS team has introduced.  Things were working, they changed something, and now its broke.  This needs to be fixed, not voted on.

blopez11
Resident Rockstar

Geez, I've been fighting this for the past few days, thought I was going crazy.  Decided to check the issues page and find it is not just me.  I am getting the same type error as original poster.  I am using a composite model as well, including Direct Query to Power BI dataset.  I have a calculated column in one of the tables in the shared dataset.  My report/dataset also resides in a premium capacity workspace.

 

It seems that this is impacting enough users that this should be addressed asap.

TSHECKEL
Advocate II

I had submitted a request through our Power BI subscription support team and I received the following notification this morning. 

 

This is a follow-up message. The product team has developed a fix for the issue reported. This fix is going to be released to all our PBI Tenants this week. I highly recommend testing any time later than 3/10/2023.  Please keep me updated if your issue is resolved or if you require additional assistance.

 

 

chang_B
Advocate I

@TSHECKEL Thanks for the update! Looking forward to the fix.

v-yetao1-msft
Community Support
Status changed to: Accepted

Hi @chang_B 

It’s a known issue . The engineers are actively working on this issue and I will come back with an update if there is any progress.

 

Best Regards,
Community Support Team _ Ailsa Tao

CDC_JBA
New Member

Hi All,

FYI, we have been facing the same issue and we have just tested a workaround with the UTCNOW() function and it seems to have solved the issue... at least it works for the following calculated column (in Direct Query mode on a SSAS / Power dataset) :

Day Offset = //'Calendar'[Date]-TODAY() (--> previous formula)
DATEDIFF('Calendar'[Date], UTCNOW(), DAY)

Hope this helps 🙂
 
Jean-Baptiste ARZOUNIAN
 
Maieev
Resolver I

Hi @CDC_JBA ,

 

Unfortunately nothing changes in my case.

TSHECKEL
Advocate II

We've confirmed that this has now been resolved on our service(s).