Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Bookmark Navigator not showing in Published Apps

The recent feature "Bookmark Navigator" is not working properly when I publish my report into an app. I can't really understand what is happening because when I open my report in the PowerBI Service, it works fine, but when I publish it into the App it somehow disappears.


- Print in PowerBI Service: I can see, click it, works well.

Captura de tela 2021-11-24 114015.png

- Print in Published App: the Visual header still showing, but the Buttons itself somehow invisible and unusable.

Captura de tela 2021-11-24 113834.png

Did someone have the same issue? I tested it opening the report separetely in another tab and it works fine, only in the App that I can't see the new feature Bookmark Navigator.

Status: Accepted

There is an exsiting ICM.

Community Support
Status changed to: Investigating

Hi @wiSama 


Please try these solutions to see whether it will be rendered properly:

1 Refresh your browser page

2 Restart your browser and reopen the app

3 Delete the app and reinstall it






Best Regards,

Community Support Team _ Caiyun

Regular Visitor

Same happening here, nothing worked so far...

Helper I

Same issue for me, have tried on a range of scenarios and workspaces but nothing,





Advocate I

@v-cazheng-msft thanks for the response!


I've tried in 3 different browsers, in my recent tries refreshing the page corrected the render issue but unfortunately this is not a common thing to do, especially the end users.


When opening the report for the first time, in all different browsers, it does not render. I would have to leave a clear message for the end-user to refresh the page right after loading it, which is a something weird to do.


Hope the team could correct this in the following updates, because this feature is time saving!

Not applicable

I'm finding the same thing. Okay in service but not in an app. I'm planning to rebuild all reports using this feature so would be keen to see it fixed. The whole bookmark navigator implementation is quite buggy - like how buttons dont unselect, they only select

Community Support

Hi @wiSama 


Thanks for your reply. I understand. But I couldn't repro it at my side. Please consider opening a support ticket by Support | Microsoft Power BI for further help. There will be a support engineer help you on your issue and escalate it when necessary.

How to create a support ticket in Power BI - Microsoft Power BI Community


Best Regards,

Community Support Team _ Caiyun



Frequent Visitor

This same issue is happening to me as well. I believe this is related to the all around issues with the bookmark navigator. It wasn't rendering properly when it was first released (there are at least 2 threads about this). When I first published a report to an app in mid-November with this, it showed up - but now it is no longer showing up even though it is clearly present in the desktop report.


I would refrain from using this feature until the Power BI team has all the kinks worked out.

Not applicable

It is very buggy.   I have to keep republishing.

Advocate III

Same here. It works in your regular workspace, even when sharing the report, but taking it up in an app kills the Bookmark Navigator.


This was already an issue in the November update, unfortunately nothing changed in the December release. Of course it's a preview function, so you may expect an issue here or there, yet, this shouldn't have been released imho. It doesn't even work in it's most basic form. Instead of saving me time, it has already cost me a lot of time by now...


It's not exactly the only issue in the last release either. It seems preview functionality gears more towards alpha testing.

- The Navigator bookmark alone featured several bugs, most of which are still present, such as the deselection still not working as it should. (Still not in the December update, you can trap yourself in the deselected bookmark, with the button lit up, unable to click it, until you click away with a different bookmark)

- The new formatting pane is able to trap you in Desktop under certain conditions (I locked myself out of the visual selection window, trying to change the Chiclett Slicer 1.6.3 to a different visual with unsupported formatting options).

- Buttons don't work with the new formatting pane...

- And I haven't quite figured it out yet (as in when and where), but ever since the November update, I'm often experiencing problems dragging measures into fields of charts or tables. Sometimes it worked with a workaround (right-click add to field), sometimes not. Afaik this is new behavior too.


And I'm really not trying to do anything too fancy. This all happened while working one one relatively simple report. Guess I'll be writing some more bug reports. 😉


Forgive my rant, still love you guys, keep up the good work!

Community Support

Hi All,


This is an ICM(278899875) related to Bookmark Navigator gone in app. I'll follow up it and sync with you here once there is any update. Thanks.


Best Regards,

Community Support Team _ Caiyun