Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Apply changes not working



With August'22 version I have an issue when I try to apply changes or discard them.


Seems not working neither:









Status: Investigating

Hi @cristianml,


Please rollback to previous version of PBI Desktop. If you coundn't do that, please reach support engineer by support ticket for further help.


Previous monthly updates to Power BI Desktop and the Power BI service - Power BI | Microsoft Docs


Best Regards,    

Community Support Team _ Caiyun

New Member

I got a similar  issue. I work with Powerbi for a long time and suddenly the pending changes yellow bar does not work.

Pressing Apply Changes boots a Query Metadata popup that says that the data has been loaded and nothing happens

Pressing Discard Changes I get the same Parameter screen as "cristianml'

I can not refresh any cube! Its awful!

Loaded my back up projects and I get the same pop up even if I havenot made any changes in months. I think that the issue might be related with a Windows update since this started happening after I updated with the latest windows update

Regular Visitor

I have the same issue. Any solutions?

Regular Visitor

Same here. What shall I do???

Regular Visitor

Same issue with @blipblipblue 


I have multiple reports using by Power BI desktop and one of .pbix file suddenly popup pending changes once I opened file by PBI desktop August 2022 (MS Store) version and it's unable to remove the popup by refreshing data and queries while the other .pbix files don't have any issues.


Lastly I tried to clear all caches and restart Power BI desktop, could eliminate this issue.

Regular Visitor

I tried clearing cache and reinstalling Power BI Desktop but it doesn't work for me. Any luck from anyone else?

New Member

Having the same issue. Seems like a bugged version has been released. Among that the Desktop app takes a long time to perform small actions, has issues with loading data etc. Hoping for a quick patch.

Super User

Yep  super annoying, getting this in every pbix I work on,  must be the latest update?  

Frequent Visitor

Yep, I got this issue too. None of my reports connected to the existing dataset would load either.

I uninstalled Power BI and reverted back to the July version and I'm back to normal.


You can find previous versions of the desktop here: 

New Member

I got it! There are "helper queries" in power query. Some have errors. I deleted all of the helper queries with little yellow exclamation points next to them and the box dissapeared! It seems prior versions of PBI tolerated helper queries with errors. Let me know if this works!



Regular Visitor

Following @Jay_Mitchel and @cdlawrence solution (thanks so much! 😊), I reverted back to the July version and this works! I can successfully refresh my data sets and publish as usual.

Here's the download link to 

Hope it works for you too.