Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Apply button is greyed out when adding a data source to the on-premise data gateway

I noticed when I published a report with an on-premise data source (SAP BW) along with cloud data sources (Sharepoint), the Apply button is greyed out in the gateway connection settings:

benz_te_1-1673591313177.png

 

Again, this is only applicable to newly published datasets.

For the existing ones, there are no errors, and I can refresh successfully. Like this one, it has actually the same setup, just published in a different workspace some time ago:

benz_te_2-1673591452920.png


I just experienced this yesterday. 

Any of you are experiencing it now?

Appreciate the responses!

EDITED--

 

Check out the comments for the workaround

 

Microsoft has also posted the issue on the Power BI Support page. Expect the fix to be on 24th of January

benz_te_0-1674180041548.png

 

Status: Accepted

Hi @Anonymous ,

 

This is acknowledged as an issue. We have reported the issue and submitted it to the internal icm platform, No:360537118 . Engineers will do their best to resolve the issue. I will update you here if there is any progress , please be patient.

 

 

Best regards.
Community Support Team_ Caitlyn

 

Comments
kumar9999
Frequent Visitor

Even im facing the same issue from yesterday. One of my source is a sql server and 2nd source is a sharepoint list, when setting up gateway, the apply button is greyed out.

Gladiator909
Helper I

This is really weird, I have pretty much the same setup and it was working fine until recently.

 

I think if you remove the "sharepoint" site, the apply button becomes enabled. however, like I said, it was working fine before even with the sharepoint site there....

v-xiaoyan-msft
Community Support
Status changed to: Accepted

Hi @Anonymous ,

 

This is acknowledged as an issue. We have reported the issue and submitted it to the internal icm platform, No:360537118 . Engineers will do their best to resolve the issue. I will update you here if there is any progress , please be patient.

 

 

Best regards.
Community Support Team_ Caitlyn

 

Anonymous
Not applicable

Interesting to know there are others who are expieriencing the same issue.

Appreciate the response Caitlyn, looking forward to the resolution

ntdanh
Frequent Visitor

same issues here....

ntdanh_0-1673852454595.png

 

huynhzy
New Member

Same issue here. Looking forward to the resolution.

Anonymous
Not applicable

To anyone experiencing the issue, there is actually a workaround. You need to turn on the Developer Tools of your browser, then select the radio button, and Apply button, then change their properties to 'enabled'

Radio button:

benz_te_3-1673855386560.png

 


Apply button:

benz_te_2-1673855370638.png


There should be changes, and it might say it still in error, but the refresh/scheduled refresh will work

benz_te_4-1673855482663.png


Again this is just a workaround, just for anyone who needs to fix their refresh issues in the PBI Service asap

As mentioned by v-caitlyn-mstf, this is an acknowledged issue and hopefully they will resolve it soon

alessandrolops9
Regular Visitor

I have the same problem. There is a solution?
could the problem be caused by the latest version of the service?

ntdanh
Frequent Visitor

@Anonymous It works ! I have followed your tip and enable options to make a refresh scheduled !

OwsikAgata
New Member

same problem