Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Analyze in Excel connection problem - failed to connect to the url https //api.powerbi.com while att

My Analyze in Excel report worked fine until few days ago.

Now, when I'm trying to connect to old file, or generating the new .odc file, I'm receiving following error.

 

Capture.JPG

 After clicking OK, file is closed, don't have even the ability to change connection data.

 

I'm able to connect powerbi service with the same account, have an admin privileges and can access the PowerBi Service dataset and its report. The problem consists in the MS Excel itself.

 

Following the steps here:
https://docs.microsoft.com/en-us/power-bi/collaborate-share/desktop-troubleshooting-analyze-in-excel

 

Installed new version of OLE DB drivers many times, also by uninstalling previous versions and repairing the existing ones.

Using only 1 - same account across the applications.

Any additional steps that I can make in order to get more details about this issue ?
Same issue someone ?

Status: New
Comments
Anonymous
Not applicable

Hi,

 

I'm having same issue for last 3 days now. 

 

https://community.powerbi.com/t5/Issues/Failed-to-connect-to-the-url-https-api-powerbi-com-while/idi...

 

No idea where it is going wrong. please update if you find a resolution. 

 

Thanks,

Awanish

Anonymous
Not applicable

My guess is it maybe an issue with the new driver: x64_15.0.2000.424_SQL_AS_OLEDB.msi which works not completely correctly in Win7 64-bit environment. My collegue doesn't have any issue with same .odc file in Win10 environment.

Reinstalled the 32-bit version of the driver but without success (by default system uses 64-bit driver).
Also Enabled TLS 1.2 as security protocol (which is disabled in win7 by default), as there was some changes in PowerBI Service in June, but that was also a blind shot.
Still don't have the solution 😞

Anonymous
Not applicable

YES! Got this solved for Win7 64-bit.


Got this solved. Solution:

1) Install the newest driver (64-bit)
https://docs.microsoft.com/en-us/power-bi/collaborate-share/desktop-troubleshooting-analyze-in-excel

2) Enable TLS 1.2 in the registry of your machine (this step may be optional if you install step 3)
https://help.runbox.com/enabling-tls-1-2-on-windows-7/
3) Apply the Easy FIX by installing this or manually by steps described below. (I installed the EasyFix).
https://support.microsoft.com/en-gb/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-sec...

 

You're welcome! 🙂