Showing results for 
Search instead for 
Did you mean: 

AWS PostgreSQL - PowerBi Service



First, thanks to the PowerBi Team for finally enabling PostgreSQL Direct Query also on the PowerBi Service. Since this weekend the error of the missing "Npgsql" is gone and the date source is now valid.

But unfortunately if the PostgreSQL service is running on AWS RDS service it is still not working.


Error Message: 

Cannot load model

Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again.

Please try again later or contact support. If you contact support, please provide these details.

  • MessageAn error happened while reading data from the provider: 'The remote certificate is invalid according to the validation procedure.'
  • Activity ID d963e1f9-4dd2-4d1a-8e37-5b39359917ab
  • Correlation ID e843d331-5e6c-7b91-19df-715289d8e1f4
  • Request ID 1ceba9ba-7b87-523e-32e6-1256605bacf2
  • Time Mon Nov 18 2019 13:05:40 GMT+0100 (Central European Standard Time)
  • Service version 13.0.11428.174
  • Client version 1911.2.021
  • Cluster URI


I know this is a manual step in working with PowerBi Desktop, there you can deploy the root certificates manually. How should this work on the PowerBI service? 




Status: New
Community Support

Hi @Anonymous, 


Does the dataset require any gateway to refresh data? If it is, please install the proper certificate on the Gateway machine to allow an encrypted connection to work.


Best Regards,
Qiuyun Yu 

Not applicable



No, this dataset does not require a Gateway. Thsi fuctionality is really new, maybe you can get hold of someone who has worked on the PostgreSQL Direct Query implementation on the Cloud service.



Frequent Visitor

I'm having a similar issue.  PostgreSQL DB via AWS and after DirectQuery.  Gateway has been updated and yet:

Not applicable

@Anonymous @v-qiuyu-msft were you ever able to get PostgreSQL on AWS RDS to work with PBI Service? we're still having issues, where we can get it to work on Desktop, but not in PBI Service... 

Frequent Visitor

@Anonymous , I managed to get it to work - however only once I'd removed any relationships (either joins in the SQL query or between tables in Power BI) by creating a view in my schema that gave the appropriate granularity and fields required without any changes in query editor or DAX measures, etc.  Hope that helps

Not applicable

@jpd99 thanks for the reply and suggestion! Unfortunately, I don't have so much control over the database. So far I've relied pretty heavily on the query editor and Dax measures to get what I need 😕 The error almost makes it seem like PBI Service doesn't actually have the latest Amazon RDS CA certificate installed?

Frequent Visitor

@Anonymous I think you're right! Currently facing the same issue

Not applicable

@Anonymous :


I've tested it again and it still does not work. It seems that Microsoft doesn't want that people are using AWS cloud databases, which is really annoying since then PowerBi service is not an option anymore.



Frequent Visitor



The way I resolved it was to have an always-on laptop >> Install the Gateway there >> Run the usual set-up


Now I can publish a dashboard from any other laptop, and the refresh will occur as usual