refresh OK in Desktop but KO in Service (with dataflow as source)
Hi,
I have my .pbix that use Power BI Dataflow as source.
The refresh in the Power BI Desktop works well.
When it comes to Power BI Service, the schedule refresh sometime works, most of the time (and lately) always fails with different error.
"The key didn't match any rows in the table" with different table every time.
Do you have any ideas about that issues?
Thank you,
3 Comments
- v-chuncz-msft
Community Support
You may take a look at the post below.
- AnonymousNot applicable
hey leed , same thing happened to me just yesterday (07 Feb 2020)
temporary solution I've found -- check all your dataflow entites for 'date' fields (columns) & format them as strings within the dataflow. you can change them back to dates in your report query m editor in 1...2 steps
after I've changed 2 fields in my dataflow from 'date' to 'string' format and refreshed - the dataset / report refresh in service has stopped failing to "see" the dataflow (that's what the error - key didn't match any rows in the table - in fact means, the dataset can't find the dataflow, as if it was renamed or does not exist)pls let me know if it helps!
Regards,
Dima
- leed
Advocate II
Hi Anonymous
Thank you for your reply.
It's more about an issue when sharepoint exceed certain limits (of number of files), dataflow is not able to read it anymore and it just leaves blank.
It does not exist before, the issue showed up last week (I think they might deploy something on the backend - which led to the error that you metionned like 2-3 months ago)
Best,