Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

0

When `select all` is used, then slicer doesn't respect the visual level filter

I have posted the details into a forum post: https://community.fabric.microsoft.com/t5/Desktop/When-select-all-is-used-then-slicer-doesn-t-respec...

 

Steps to replicate the issue/bug:

1. In Power BI Desktop, click on Enter Data and create a table having 2 columns. In column 1, enter values 1-10; and in column 2, enter values a-j. Load this table into Power BI.

 

nachthl_0-1712219191738.png

 

2. Now create a table visual with both these columns

nachthl_1-1712219285224.png

 

3. Create a slicer visual with column 1, SLICER TYPE should be dropdown, and under SELECTION choose `Show "Select All" ...`

 

nachthl_2-1712219374573.png

nachthl_3-1712219417064.png

 

4. Click on the slicer visual, and under the filter pane -> `Filters on this visual` -> filter on this column such that it shows items with value less than 4, and click on `Apply Filter`

nachthl_4-1712219498904.png

5. Now your slicer will show values from 1 to 3

 

nachthl_5-1712219512472.png

6. If you select any slicer value, the table visual will get filtered to show that record.

nachthl_8-1712219621534.png

 

7. However, if I choose `Select All`, with the intention that the table should show data for all items in the slicer, then the table visual shows all values. Shouldn't it only show 1 to 3?

 

 

nachthl_7-1712219604062.png

 

 

Status: Delivered

Hi @nachthl ,

 

It's by design and not a issue..
There are several filters in Power BI and you can see their differences here.

Types of filters in Power BI reports - Power BI | Microsoft Learn
To accomplish what you want, you can either use a page-level filter or hold down the ctrl key and check each of the three options 123.

 

Best regards.
Community Support Team_Caitlyn

Comments
v-xiaoyan-msft
Community Support
Status changed to: Delivered

Hi @nachthl ,

 

It's by design and not a issue..
There are several filters in Power BI and you can see their differences here.

Types of filters in Power BI reports - Power BI | Microsoft Learn
To accomplish what you want, you can either use a page-level filter or hold down the ctrl key and check each of the three options 123.

 

Best regards.
Community Support Team_Caitlyn

nachthl
Frequent Visitor

@v-xiaoyan-msft - are you saying that if I select the `Select All` checkbox in the slicer (screenshot below), then, it is by design that it doesn't restrict the table visual to 1, 2, 3 only? In that case this is very misleasing and Microsoft needs to look into this. Does the below screenshot make any logical sense to the end-user? What can I do to escalate this as something to be looked into by Microsoft please?

 

nachthl_0-1713178049536.png

 

v-xiaoyan-msft
Community Support

Hi @nachthl ,

 

If you would like to suggest feature improvements, you may vote the idea and comment here to improve this feature. It is the right place for customers provide feedback about Microsoft Office products . What’s more, if a feedback is high voted there by other customers, it will be promising that Microsoft Product Team will take it into consideration when designing the next version in the future.

 

Best Regards,
Community Support Team _ Caitlyn