Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Theme setting indicatorDisplayUnits for kpi does not work

It seems like the theme setting indicatorDisplayUnits for visual kpi does not work. The value in Power BI updates accordingly but it doesn't affect the visual.

 

Theme.json

{
	"name": "Test",
	"visualStyles":{
		"kpi":{
			"*":{
				"indicator":[{
					"indicatorDisplayUnits": "1000"
				}]
			}
		}
	}
} 

 

Status: Accepted
Comments
v-yulgu-msft
Employee

Hi @svantegraden ,

 

The available values for "indicatorDisplayUnits" key should be Auto, Millions, Billions, etc. 

 

Please refer to sample code in this blog. Also, you could check the common JSON format applied for KPI settings, as mentioned in this article.

"indicator": {
        "indicatorDisplayUnits": {
          "type": [
            "formatting"
          ],
          "displayName": [
            "Display units"
          ],
          "description": [
            "Select the units (millions, billions, etc.)"
          ]
        },
        "indicatorPrecision": {
          "type": [
            "numeric"
          ],
          "displayName": [
            "Value decimal places"
          ],
          "description": [
            "Select the number of decimal places to display for the values"
          ]
        },
        "kpiFormat": {
          "type": [
            "text"
          ],
          "displayName": [
            "Format"
          ]
        }
      },

Best regards,

Yuliana Gu

svantegraden
Regular Visitor

Doesn't work.

 

Default

DefaultDefault

 

When setting

"indicatorDisplayUnits": "Thousands"

the result in Power BI Visualization Pane is "Trillions" but the KPI visual displays as None (full value).

"indicatorDisplayUnits": "Thousands""indicatorDisplayUnits": "Thousands"

 

When setting

"indicatorDisplayUnits": "1000"

the result in Power BI Visualization Pane is "Thousands" but the KPI visual displays as None (full value)."indicatorDisplayUnits": "1000""indicatorDisplayUnits": "1000"

The string 1000 works for Clustered Column Charts.

"clusteredColumnChart": {
	"*": {
		"valueAxis": [{
			"labelDisplayUnits": "1000"
		}]
	}
}
v-yulgu-msft
Employee

Hi @svantegraden ,

 

I have reported this issue internally, CRI: 122577405. Would update here once I get any response.

 

Best regards,

Yuliana Gu

v-yulgu-msft
Employee

Hi @svantegraden ,

 

Product team is investigating this bug, and it would be fixed in August release.

 

Regards,

Yuliana Gu

v-yulgu-msft
Employee
Status changed to: Accepted
 
mcriste
Regular Visitor

Hi.

 

Am experiencing the same issue that was delineated above.  Apparently this issue has not been fixed.

 

Can you give me a status update?

v-yuta-msft
Community Support

@svantegraden ,

 

Issue has been fixed currently.

 

Regards,

Jimmy Tao

svantegraden
Regular Visitor

@v-yuta-msft, in which version? I'm running 2.84.802.0 and the issue still exist.