Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Slicer (new) resetting default

Hi, 

I posted about this in the forums and seems like more than me are seeing the same issu. 

 

The new button slicer keeps resetting to the left most button even though it is saved in another state. 


As an example I have a report with year filter (year from date table) and timeperiod filter (calculation group), I have it saved as 2023 and YTD but when closing and reopening the report it is set to 2022 and MTD. Same behavior in service.

 

adnyk_0-1700732030747.png

 

adnyk_1-1700732030969.png

 

Br 

Adrian

Status: Investigating

HI @adnyk 

I created a new slicer in Desktop, selected 2023, and then published to Service, with the new slicer selection remaining the same as before.Do you have any other filters set up besides slicer, or can you provide your sample for testing?

How to provide sample data in the Power BI Forum - Microsoft Fabric Community

vyetao1msft_0-1700812766614.png

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Investigating

HI @adnyk 

I created a new slicer in Desktop, selected 2023, and then published to Service, with the new slicer selection remaining the same as before.Do you have any other filters set up besides slicer, or can you provide your sample for testing?

How to provide sample data in the Power BI Forum - Microsoft Fabric Community

vyetao1msft_0-1700812766614.png

Best Regards,
Community Support Team _ Ailsa Tao

adnyk
Advocate II

Hi @v-yetao1-msft 

 

Sharing a test i did, it seems to work when not altering the visual settings for the slicer. In the test file i have 3 slicers with modified settings (rounded corners, padding, color etc) they reset to first item and 1 slicer without any modifications that keeps saved state. 

 

Link: Testreport

 

Br 
Adrian

debiagui
Helper II

The same in my side

renanvpx
New Member

Same thing, also I noticed that the sync between pages is also not working when using the new slicer.

nandic
Memorable Member

Same here. Once slicer has been customized (formatted), it doesn't save selected (default) item. When reopening the file, it always resets selected item to the first item in a slicer.

yannisT
Regular Visitor

Same here, slicer does not "remember" saved positions. This was always the case from day one.

adnyk
Advocate II

@v-yetao1-msft 

Any update on this? 

Will it be fixed in upcoming release?

 

Br
Adrian

Daniel_PBI
Frequent Visitor

@v-yetao1-msft 
Pleae provide an update when a fix is planned.
Thank you and best,
Daniel

jhoffmann
Frequent Visitor

We are experiencing this exact same issue. Very annoying as we use slicers extensively, often with a default selection. The benefits of the new slicer (more advanced customization options) are completely negated by this technical issue.

JustinKropp
Regular Visitor

I've noticed the issue only occurs on existing/old pages.  If I create a new blank page with the slicer it works as expected.  It stops working when I copy a visual from another page to the new page.  Looks like it's corrupting the slicer selection cache or something.  Very annoying.  Preventing us from using the new slicer for now.