Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Pendig changes: query metadata don't get updated


I have some Power BI Boards which I edit once a month within the desktop app.

When I opened the boards yesterday I got a notification, that there are some pendig changes that have not yet been applied.


When I select "Apply changes", Power BI updates "query metadata":

Screenshot 2022-08-10 161652.png

For a moment a green tick is displayed.

However, the message "There are pendig changes" remains and I can't refresh my dataset.


When I select "Discard changes" nothing happens at all.


Does anyone know what are the pendig changes about? We didn't make changes to the dataset since last time.

How can I solve the pending changes to refresh my dataset?

Status: Delivered

Hi @MariaC 

I am so glad to hear that your issue has been fixed with other users' suggestions . At present, there are many problems with Desktop in August, so it is recommended to use the Version in July first, and then use it after the problem is updated in August . 


Best Regards,
Community Support Team _ Ailsa Tao

New Member

I too am experiencing this but found a solution that may or may not work for you. When discarding changes, is it listing parameters? If so, select transform data (power query) and refresh the helper queries or anything to do with parameters. Close & Apply, the message should disappear.


Hope that helps.


New Member

Thanks a lot! That solved the problem with the pending changes.

Unfortunately, I'm still not able to refresh my dataset. For a second there appears an error message, that the queries are blocked. Do you have any idea how to solve this, too?

Not applicable

I am having the same issue with a report that I refresh weekly.

I also tried older versions of the report - but they have the same issue


It is listing parameters as the pending changes.


I see one user suggested refreshing helper queries - but  - I am not sure how to do that, - I did try refresh preview and refresh all, but that did not help.


This problem did appear after the August update.

Not applicable

I was able to get around this error by opening the manage parameter dialog box - then just clicking okay.  I had to do this for all parameters - an then the error went away.  



Super User

Nice workaround @Anonymous 👍

Let's hope a fix is forthcoming


Regular Visitor

Hi @MariaC 

In the meantime, have you made any changes? Like updating the version of your Desktop ?

New Member

I am having the same issue. Refreshing the helper queries removed the pending changes issue, but still having the same issue that the queries will not refresh. Does anyone have a solution?

New Member

Thank you so much @Anonymous. That was the trick!


@JamesDyerafter fixing the helper queries there are two options to solve the queries refresh:

a) First refresh the preview within the power query editor. Then refresh the queries in Power BI.

If this doesn't help, I was able to get around this error by following:

b) Confirm the last step of the "Applied steps" of every query just by clicking the gearwheel and okay.


After I did this for every query in the power editor I was able to refresh the queries in Power BI.

I hope that works for you, too.

New Member

Thanks for the reply @MariaC, tried all the above steps. Unfortunately still not working 😐, still briefly coming up with the "loading blocked..." error then disappearing...possibly because the last steps on some of the queries do not have a gearwheel, not quite sure why. I clicked the gearwheel on the latest possible step on each query. 

New Member

@JamesDyer instead of the gearwheel you can click in the editing toolbar behind the last sign and confirm the step with pressing enter.