Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

NEW BUG: Bigquery connection error - DataSource.Error: ODBC: ERROR [42000] [Microsoft][DSI]

Hi All,


I have some qeird error in my PowerBI. When I try to connect to the bigqeury views I get this error:


DataSource.Error: ODBC: ERROR [42000] [Microsoft][DSI] An error occurred while attempting to retrieve the error message for key 'GApiErr' with message parameters ['Access Denied: BigQuery BigQuery: Permission denied while getting Drive credentials.'] and component ID 100: Message not found in file "C:\Program Files\Microsoft Power BI Desktop\bin\ODBC Drivers\Simba Google BigQuery ODBC Driver\en-US\SimbaBigQueryODBCMessages.xml"


The problem is that it works for some views and I got this error for other views, there is no pattern like different naming etc.

Also I reinstalled PowerBI, tired to use previous versions, tried on a different company computer, changed permission rights, tried different connections etc. but without success.

I also checked it using different users with windows and it is exactly the same. Cleaning cache does not work as well.

At the beginning I thought that it may be related to the latest windows update, but I removed all the windows updates and it is still not working.


Any ideas what the error is or how to solve it?

Status: Investigating

You can create a support ticket in the end of the support page:



About tracing Power BI, see:

  1. How to collect a trace in Power BI Desktop 
  2. Use Fiddler to trace 


Best Regards,
Community Support Team _ Yingjie Li


Helper I

Hi! Since today I get this error for all my BigQuery imports. Could somebody please help?

Frequent Visitor


Did you manage to solve this issue? 

Frequent Visitor

@Anonymous  / @TatiparthiKiran 


I face the same issue and I did not fully understand your solution. Could you provide some screenshot or describe a bit more in detail?


Had this issue for two weeks now without any soluton so this would be much appreciated!