Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Issue with Measure Field names not being found upon refresh

Following an update today to - PBI Desktop version 2.79.5768.1082 64-bit (March 2020) -

I am unable to refresh multiple files in which empty tables have been added, to collect Measures together (so contain no columns).


At each refresh attempt, the failure reason given against ALL Fields is -

"The model doesn't have a named expression named [Insert Measure Table Name]".


If then going into Query Editor and changing the name, the file will refresh successfully. 

However, after saving and reopening the same errors recur, this time with the new name of the Measure Table. 

I have tried this several times and each time after saving and reopening, the same failure occurs, related only to the Measure Tables.


Is there a problem with Query Fields that have been generated by using the "Enter Data" function from the Report side of Desktop, that then have redundant columns deleted, so as to only hold Measures?...


This is a hugely frustrating issue!

Status: New
Community Support

Hi @russellwillis


Besides entered data, did the report get data from any other source? If it is, please check if the source table structure is changed before you refresh the report. 


Best Regards,
Qiuyun Yu

Regular Visitor



Thanks for your response.

Yes the report gets data from another source, with several queries connecting individual tabs of a single excel file (saved within SharePoint and using the SharePoint Folder connection connector).

Everything else in the source data is stable now, following another glitch, since solved -


I have had to remove line breaks from source column headers as columns containing "#(lf)", could not be found and caused the refresh to fail... Removing the line break in source column header, then adjusting the query to remove "#(lf)", solved this issue.


Once editing the names of the Measure Tables (Empty tables in which I place my measures for easy reference, rather than within each data source field), within Query editor, the named expression error does not occur.

However, if changing the name from the report side of Desktop, the named expression fault persists.


Then after saving/closing/reopening, then named expression error returns, even though showing the new names for the Measure Tables.

Then renaming again, vie Query Editor, even if reverting to original name, the fault is again cleared.

But... save/close/reopen/repeat...

Regular Visitor

In further update to the above: Simply deleting the Query step that removes the redundant column (which then restores the table to a formal table, rather than the "Measure" tables I have configured) allows the refresh to complete.

So it seems the issue is that a table is defined with zero columns, stops the Query being able to find the named table, as per the below fault -

"The model doesn't have a named expression named [Insert Measure Table Name]"


I particularly liked the facility to create standalone "Measure Tables", which when having zero columns always showed at the top of the Fields list, to make administration of Measures simpler.

Please re-enable the abiltiy to do this, without breaking the Query Refresh process!