Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Invalid credentials on Sharepoint folder

Since yesterday I'm having an issue connecting to an excel file in a Sharepoint folder. It was already working, but I made some changes and republished it. Refresh works fine in Power BI Desktop, but online. It seem it's trying to connect to a Sharepoint list, instead of folder. I have an other report connecting to an other excel file in the same folder and it works fine. Could this be connected to the issue in North Europe? I'm in that datacenter.



Status: Accepted
Regular Visitor

I am also experiencing the same isssue. Tried multiple ways but no use. 




What authentication methods can you see after you click edit credentials? Is OAuth available in the method list?

Same issues have already been reported: CRI 26535010, CRI 26289174, CRI 26550194. Power BI Team are working on them.

I’ll keep an eye on them and post here if there is any update.


Invalid credentials on Sharepoint folder_1.jpg


Best Regards,


Advocate II



OAuth is not in the list. Thank you, please keep me posted.

Advocate II

I assume, this is an error during the publication of the report. An old one works just fine, saying 'SharePoint' instead of 'SherePointListOnPremise' in the marked area on my screenshot. All my reports are 'Save As' from each other, connecting to different excel files with the same structure. The ones I've republished recently stopped working, the old one is fine.

Frequent Visitor

I am having the same issue, has anyone found a solution. My datasource is excel files from one drive.





Data from SharePoint and OneDrive should be two different issues. Can you see the OAuth2 method in Authentication method?


In Power BI Desktop, I get data from a excel file on OneDrive for Business with the steps in this official document. After I publish it to Power BI Service, I try to change the data source credential to OAuth2. Everything looks fine until now. But once I click edit credential again, the credential reverted to Anonymous. If I click refresh now, the refresh will be failed.


I find that there is already a same issue reported (CRI 21446391). Power BI team are working on it. Based on the information I get, the fix maybe available later this week (11/26). Please try it later and post back if issue persists.


Best Regards,


Impactful Individual
Status changed to: Accepted
Regular Visitor
Appreciate any updates on this issue. I'm having the same error message and my source file is SharePoint List (online). Really hoping this would be addressed soon as we are and will be using PowerBI for an upcoming campaign in our organization.
New Member

On my case : my datasource is  sharepoint online list , when using PowerBI Desktop I got data and choiced

 [sharepoint online list] , it works fine , then I published it to Power BI .  I log on Power BI, and my dataset become SharepointListOnPremise , and then click [edit credential] ,there is no OAuth2 .

I think it should be Sharepoint instead of  SharepointListOnPremise......






Not applicable

Facing the same issue here and agree with all comments.

We need some workaround for this ASAP, please! For the sake of our delivered solutions...:S