Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Failed to update data source credentials

Hello, 

 

I built a report in Power BI desktop from excel table stored in Sharepoint.

I published this report in power BI service and created a dashboard. 

Everytime I am trying to update the report I receive the following error message : 

Failed to update data source credentials.Hide details

Activity ID:2e9a503f-01c4-429f-a266-e091d0b336b0
Request ID:176e7558-f852-d8bf-a2d6-6c9f0a04cf62
Status code:400
Time:Thu Mar 02 2017 10:22:45 GMT+1100 (AUS Eastern Daylight Time)
Version:13.0.1700.1256
Cluster URI:https://wabi-south-east-asia-redirect.analysis.windows.net

 

Also I can not load my organisation Dynamics data. 

 

What can I do ? 

 

Thank you 

 

Regards 

 

Julie 

Status: Needs Info
Comments
jvaught
Advocate I

having the same problem with Salesforce. I can connect in desktop, but get "Failed to update data source credentials:" when trying to use the same credentials for the refresh schedule on the dataset in the power bi online app.

pyoungberg
New Member
Make sure you publish your data from the O365 admin center Reports page https://portal.office.com/adminportal/home#/reportsUsage. If it still says "We're getting your data ready for the Office 365 Adoption content pack" you need to wait.
dvaughn
New Member

I received the following error via email.

An error occurred while processing the data in the dataset.

Refresh failed:
Azure Enterprise has failed to refresh.
Failure details:

The credentials provided for the AzureEnterprise source are invalid. (Source at https://ea.azure.com/rest/redactedenrollmentnumber.) Table: Usage Details.

 

I tried updating my API key and setting up a new connection. Still getting this error.

 

Failed to update data source credentials: Web.Contents failed to get contents from 'https://ea.azure.com/rest/redactedenrollmentnumber/usage-reports?type=summary&month=2015-12&api-version=1.0' (426): Upgrade RequiredHide details

Activity ID:c5ba9620-8467-4656-94c0-78a48a24ffaa
Request ID:c2bb054d-64ad-18a3-a007-cc9fd40d2011
Status code:400
Time:Thu Jan 10 2019 12:41:19 GMT-0500 (Eastern Standard Time)
Version:13.0.7840.225
Cluster URI:https://redacteddatacenterlocation-redirect.analysis.windows.net

 

Any help would be appreciated.

Anonymous
Not applicable

 As @jasethnz mentioned here: https://community.powerbi.com/t5/Issues/Failed-to-update-data-source-credentials/idc-p/150375#M5253

it is likely MFA causing the issue for me - I am trying to connect to Azure app insights...

 

I am not going to be able to turn off MFA as my enterprise security context requires it.

 

Is there a way around this? Or does Microsoft plan on fixing this?

Anonymous
Not applicable

Hey Luke,

 

you probably need to use a service account, that doesn't use MFA, and has just enough permissions to be able to retrieve the Azure App insights data.

Just give it a really long nasty password...

 

Thanks

Craig

 

Anonymous
Not applicable

Hi

 

I am having a similar issue when updating a report/dataset. 

The dataset is from from excel sheet  in Sharepoint.

I have published this report in power BI service

Everytime I am trying to update the report I receive the following error message 

 

 
Activity ID:c204d515-06ae-445d-b677-b1f3bc6d9dd1
Request ID:c78ef477-83ce-f6ec-2d02-f0d5404ab600
Status code:400
Time:Fri May 15 2020 13:23:46 GMT-0700 (Pacific Daylight Time)
Service version:13.0.13172.204
Client version:2004.4.00903-train
Cluster URI:https://wabi-north-europe-redirect.analysis.windows.net/

 

Failed to update data source credentials: The credentials provided for the Web source are invalid. 

 

I am using "Basic" for authentication method. and the privacy setting is set to organization. 

 

Any help would be appreciated. 

 

Thanks

M

 

luchitogiuse
Frequent Visitor

Hi, i have the same issue, 

 

Error 400: the credentials provided for the Web source are invalid. (Source at https://api.estadisticasbcra.com/usd_of.)

 

In desktop works fine, in using anonymous cause i have token, and i'm using gateway. 

 

 

 

 

OBMBI
Frequent Visitor

I had the same problem in PBI service where it would refresh the data source in PBI desktop and after a lot of trial and error, I unticked 'Skip test connection' which worked after I then refreshed the dataset. 

 

Hope this helps someone

OBMBI_1-1625239219256.png

 

luchitogiuse
Frequent Visitor

@OBMBI thank's! it worked ! 

 

 

Anonymous
Not applicable

Hi ,

 

We are connecting to Sage application data through ODBC driver.

Everything is working fine in Power BI Desktop.

But when we try to schedule refresh through personal gateway in web portal of power BI , on providing the same credentials(which are working in power bi desktop)  the following error is thrown

krititelang_1-1625596150988.png

 

Using basic authentication method. 

Please guide or provide suggestion to fix that . We have checked odbc versions and everything.

Do we need to try through enterprise gateway ? We are trying through personal gateway.