Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

[BUG] Measure is not visible in report connected to Power BI Dataset

I have a report wich is connected to a Power BI Dataset. In this report I've created several measures.
Now when I save my report and then reopen it in Power BI I can't see my measures.
The visuals that use these measures all say: something's wrong with one or more fields.

The measures should be in the FactEntries Table. But as the picure below shows they are not.

AlexZ_0-1619606790232.png

If I now go to the Model blade and look at the FactEntries table again...

AlexZ_1-1619606928555.png

The measures are right there.

If I hide and unhide the measures and then go back to the Report blade, the measures are showing and the visuals are working as if nothing has happend.

However they will only be visible in this session, saving and reopening the report will cause the measures to be 'gone' again. This is also the case when the report is published to a workspace so the reports can't be used until this is fixed.

Hope you can fix this soon.

 

Kind regards,

AlexZ

Status: New
Comments
v-chuncz-msft
Community Support

@AlexZ 

 

The latest version works fine for me. Try to recreate the report.

AlexZ
Frequent Visitor

Hi @v-chuncz-msft,

 

I recreated the report as you suggested and for now there is no problem with the measure disappearing.

Although this seems to be working I still want to know what caused it, since I don't whant to run into this again.

 

Because I didn't like recreating my reports due to something like this I've also tried to connecting the report to a different dataset (same dataset but with a defferent name) and saving the report as template and then starting from the template, but everything I tried seemed futile.

If I have the time I will try to recreate the problem with the new reports, when I succeed I will update this post again. I think it might have something to do with with the measures being in both the dataset and the report when I started moving the measures from the dataset to the report.

AlexZ
Frequent Visitor

Hi @v-chuncz-msft 

 

Today I needed to add another measure to the report.

At first when I clicked 'New measue' from the ribbon it appeared as if nothing happend. So I clicked it again, wich resulted in Power BI Desktop ending up in a dead lock showing a pop-up with the message working on it. After terminating PBI Desktop through the task manager I restored the report from the recovered files, only to find the measures to be 'gone' again.

Luckily reconnecting the dataset through Data source settings fixed it for me this time. But I guess there is some sort of underlying issue that's causing this to happen.

 

Mrtnkbg
Advocate I

Hi @AlexZ ,

 

I am experiencing something similar, se my thread here: Certain measures in downloaded pbix seems to disap... - Microsoft Power BI Community

 

I keep my measures in the dataset, and refreshing the report connected to it makes the measures reappear in the report and that seems to "bring the visualazations to life" again. I am still checking the dataset side as described in my thread.

 

So, unfortunately I have no solution but I second your (type of) issue and because of the similarities I will keep an eye on how this evolves.

 

(I don't mean to steal attention from your issue but support it, hope this is ok?)

AlexZ
Frequent Visitor

Hi @Mrtnkbg ,

 

Thanks for sharing, and if 'stealing' attention helps to fix this issue, steal all you need😉.
At least now I know for sure I'm not the only one with this issue.