Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

All data from power platform dataflows in my workspace broken started 22 April 2021

All the data from power platform dataflows that works perfectly a day before, giving error:

Expression.Error: The column 'entityName' of the table wasn't found.

since 22 April 2021.


The same dataflows have been working perfectly fine since January 2021.


Status: New
Community Support

Hi, @huic 

According to the error message, you might have some steps that reference the column ' entityName' which has been removed or renamed, or any other operation when you modified the query. It could be a step where you renamed, re-ordered columns, changed data types, removed other columns, etc.


Directly, right-click on your query then select Advanced editor. Here you can see the name of columns/object used for each step of your query, find the unfound column name, and edit it. 


Here are some similar threads as yours, please take a reference:


Best Regards,

Community Support Team _Robert Qin

New Member

This looks like an issue rather than a set up

Regular Visitor

I found the same issue after todays scheduled refresh. I did not change a thing in my report. I tried to fix it by setting up my datasets sharepoint connector again. Unfortunately, I encountered another error when entering my login information like so:


Something must have changed in the background as it seems like many people have this issue.

Frequent Visitor

I started getting the same error message starting on April-22.  This dataflow has worked for me for months and just broke with the same error message.


Nowhere in my query do i reference the name 'entityName'.

Regular Visitor

I have the same issue, starting yesterday (April 22nd)


The error I get is: "The powerquery job failed with error: Exception ExceptionType:MashupEvaluationException, ExceptionMessage:Expression.Error: The column 'entityName' of the table wasn't found."


I have no 'entityName' column in my table/dataflow.


I tried to create a new dataflow in power apps using the Power Platfrom Dataflow connector and I get the same error:


entityName Error.jpg










Super User

I have the same issue. I can't connect to any DF through Power Platform dataflow connector.


It is definitely a setup related issue as I can connect to the same DF using Power BI dataflow but not Power Platform datflow.



Please help us resolve this. I have >=50% of my connections on this.

Advocate II

I can replicate the issue both in the Service and on the April Desktop using the PowerPlatform.Dataflows() connector. The same steps in the March release of Desktop work fine.

Also deleting one step in the M script and swpping to the PowerBI.Dataflows() connector works fine both in the Service and with the April release of Desktop.

Advocate IV

@huic I submitted a ticket yesterday as a high urgency since quite a few of our PowerApps and other dependencies rely on these and they said that the engineering team finally noticed and was able to reproduce the same issues yesterday. I provided them a ton of detail and they said they're looking at an RCA and ETA for the fix as soon as possible. I haven't heard back from them since about 6 pm EDT yesterday, but if I do i'll repost here.

New Member

We are having the same problem, only in the Power Platform Dataflow connector.


This problem started on April 12 with the Power BI Desktop update, where we had previously requested support from Microsoft.


However, as of today, April 25, the problem is also present in the Power BI Service, as shown below:


2021-04-25 17_31_03-Power BI e mais 7 páginas - Perfil 1 — Microsoft​ Edge.png  2021-04-25 17_48_57-Navegador.png


Microsoft team, please test the updates first before launching to the public, these errors can yield a lot of financial loss to your customers.

Regular Visitor

I'm seeing the same problem as above, everything is fine in the Power BI Desktop (March 2021 release), no errors when publishing however when I attempt to edit credentials for the powerapps dataflow I receive the following error;


Failed to update data source credentials: We cannot convert Type to Table type.

Activity ID:94849996-20ea-45da-b94c-xxxxx
Request ID:3658c6ff-fddf-da9f-9e4d-xxxx
Status code:400
Time:Mon Apr 26 2021 08:30:12 GMT+0100 (British Summer Time)
Service version:13.0.15899.45
Client version:2104.2.05813-train
Cluster URI:


very important to see a resolution of this quickly