Skip to main content
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Able to access a report in the workspace but not in the App. "Sorry, we couldn't find that report"

I have an app with multiple reports (each correspond to one month). After publishing the March 2021 report, and updating the App, I am getting the "Sorry, we couldn't find that report". Below it says "It may have been deleted or you may not have access to view it". Neither of the statements are true, since the report can be accessed in the workspace, and with me being an owner of the workspace. 

I tried several things already:

  • Removed the report from the app, updated the app, included again and updated the app once more.
  • Outright republished the report over the existing one and updated the app.
  • Deleted the report from the workspace, published again and then updated the app.
  • Switched the workspace to different premium capacity.

None of that worked.

Any ideas?

Status: New
Community Support


i couldn't reproduce the problem.

if you could try to publish this report to another workspace to see if it works well, do not use premium capacity.




New Member

I have same issue. I have a pro license. I can see report in workspace that I'm an owner and admin of. It has been published multiple times and remove and added in the APP several times. I get "Sorry, we couldn't find that report" for this one report.

Another admin/owner has same problem for the same report.

The other reports I do not have any issue with.


I published it to a new blank workspace with a new app and it worked. How would I go about making it work with my existing workspace with several reports already there?




Helper I



Same here. 

Can see all of the reports I published in the App apart from 1, although it's available in the workspace. 




New Member

We were able to get the report to show by adding another report. The original problem report started to show.

Helper I

Thanks @jarenas ! Worked for me too!

Not applicable

I was able to solve by saving the same report with a different name and subsequently publishing. The one that wasn't showing started doing so, which I believe supports @jarenas solution.

Not applicable

I have the same issue. Any updates on that?

Advocate I

Same issue here: Published a new report for an existing app. No renaming/republishing helps.

Sorry, we couldn't find that report

It may have been deleted or you may not have access to view it.

Responsive Resident

@jarenas Jesus, not very intuitive but it solved the problem. Thank you for sharing!