Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Power BI Desktop not loading past main splash screen

Power BI Desktop worked fine through Monday (7/19), but now it won't work anymore because starting yesterday, the application won't load. The application will show the main splash screen--the yellow bar chart logo--and the Untitled report would begin loading in the background (I've tried opening an existing PBIX file, too) but the application wouldn't load. Meanwhile, I watched in Task Manager as my RAM usage shot up to 99% and stayed near there, causing the rest of my system to suffer from low memory. I've tried reinstalling, repairing, and switching to the x64 desktop version (I'm using the Power BI Desktop application from the Microsoft Store). 

Is anyone else having this issue?

Status: New

I ended up using a different laptop where it was working fine. After a few days I went back to my original laptop to see if anythng had changed and PBI loaded up with no issues and has been fine ever since!


Fingers crossed, in a few days it will be working for you again, sorry I can't give anymore advice than that.

Helper I

Still a fail. I took a complete wipe and rebuild of the PC to get it to work again.

Advocate I

Same problem for me but with the on-premises RS version, when a lunch Power BI Desktop RS I get a freezed splash screen.
Sometime, I don't why, after 10 minutes or more after the splash screen all goes right and the IDE start as expectd, sometime this happened after the remote desktop session is timeout.
The server machine is in an internet isolated environment as for firm enterprise policy.

The server is on a VMWare virtual machine riched via Remote Desktop:
- Windows Server 2016 Standard Edition, 64-bit Operatin System, x64-based processor
- .Net Framework 4.8.03761
- Browser: Microsoft Edge 109.0.1518.78 (64-bit), enterprise edition.
- Microsoft Edge WebView2 Runtime version: 109.0.1518.78
- RAM: 32 GB
- Display resolution: 1920x1080
- No display customization settings
- Processor: Intel Xeon CPU E5-2699 v4 @ 2.20GHz (6 processor)
- Power BI Desktop x64 (January 2023), ver 2.112.1421.0
- Power BI Report Server Ver. 15.0.1111.115
- Antivirus: Symantec Endpoint Protection (ver 14.3.558.0000)

I've used the suggested workaround about WebView2 problems adding a variable to local user:
WEBVIEW2_ADDITIONAL_BROWSER_ARGUMENTS --disable-features=RendererCodeIntegrity

but notthing to do!