Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate III
Advocate III

Query contains unsupported function. Function name: Resource.Access

My data refreshes have been working smoothly but have been giving various issues since the weekend. The desktop refresh works fine.  I also suddenly can't see options for credentials or for the Gateway that is in place. I have been having service issues since Saturday morning when first the custom connectors failed for 24 hours, then started working again, this morning the Gateway wasn't being seen by the service then briefly came back and now I can't do any refreshes at all. I suspect its something to do with the Nov release?


I receive the following message:


You can't schedule refresh for this dataset because the following data sources currently don't support refresh:

  • Data source for Query1

Query contains unsupported function. Function name: Resource.Access

Community Support
Community Support

Hi all,


Get the latest feedback:


This issue has been deployed and validated.

PROD - 11.4 QFE –12/10 and 12/11 - Sat with US clusters- Sunday.


Best regards,

Community Support Team Selina zhu

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly



View solution in original post


Confirm the resolution today. My custom connector works fine after republish the report. Thanks.

So no correction until this week-end on PROD ? So one week with this errors 🤔

Advocate I
Advocate I

Last information from our MS Ticket - Fix on MS test env





Current status : We’ve completed deploying the fix to one of our testing environments for further validation before we continue with the remaining deployment.


Scope of the impact : Your organization is affected and any user attempting to configure dataset configurations using a gateway is impacted. 


Root cause :  A recent service update contained a code error, preventing some dataset configuration requests from completing as expected, resulting in impact.

I hope they will promote it to production soon....

Advocate I
Advocate I

I'm having the same issue with a python script.

Frequent Visitor

I made a simple teste: create e report based on a Excel database. Published ok and schedule a update. Then when I made the update, everything worked.

After adding a datasource from a non certified connector extension - I have the option "Allow any extension to load without validation..." on Security options - then, when I update de report on the service I get the same error!

Reading the thread indicates fixes coming thru starting Friday, so on Saturday all published reports, (even the previously published reports that continued to work), now are failing.

Just refreshed on Desktop and Published.  Then hit Refresh on server and failed.  This is the same failure code for all previously and newly published PBI's:

Last refresh failed: 12/12/2022, 4:40:37 AM
Before the data import for finished, its data source timed out. Double-check whether that data source can process import queries, and if it can, try again.

Could this be the result of the "fix"?  Anyone else see the error move?

Helper I
Helper I

Guys, until there is proper solution from microsoft. There are some work around,
1) Shift your connection to MySQL ODBC from MariaDB

2) Shift your data temporarely to some other storage with the help of developer.

3) Role out the message in your company's network that related to this report that if anyone need information let you know, and you update the data in PBI Desktop and publish it again so that for some time they have the latest data in report.


In my  case, I had the data in MariaDB, I shifted that data to Snowflake with python script and hosted that script to AWS Lambda, scheduled it to every hour and connected my report to the Snowflake connector.


I hope the solution is on the way from Microsoft.



Frequent Visitor

Facing the same issue with MariaDB connection. Still not resolved. I made a minor change in the report and published the report. After that the issue started.

Yep. Anything new or republished does not work. I really need this fixed. 

Frequent Visitor

We have the very same issue. I think it is to do with the MariaDB connection.

Advocate II
Advocate II


this message is on the support website of microsoft power bi

hugs from brazil to everyone 😉


On the main support page as well: Support | Microsoft Power BI

Advocate II
Advocate II

Same exact issue. 


We opened a case with Micrsoft this morning, but haven't heard anything yet. Any one else?

I've specifically have the issue with custom connectors, I spoke to microsoft earlier and they took logs etc. Will report back if they have any more information. 

Frequent Visitor

Any update from MS @dp410 

I just spoke to them and provided more logs. They said the team is currently investigating the issue and they will keep me updated. 

Regular Visitor

Just adding one more that is also facing the same issue with a python script

Advocate II
Advocate II

hi guys, I'm facing the same problem right now, do you know when it will be resolved?


I'm using python script too

New Member

Same issue with Denodo connector...

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.