Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

How to remove personal gateway from



I successfully uninstalled personal gateway from my server.

But it is still visible on, with an error saying that gateway is unavailable.

I can't refresh my datasources because of this error.


Can you help me ?


Found this out the hard way, in PBI Desktop if you go to:

File -> Options & Settings - > Data Source Settings.


You might have more than one connection in the file and the wrong one was selected in our case. 


We were able to "Change Source..." and fix the issue at the PBIX file level vs each table connection.  Making sure the data source matchs the Server and Database name in your Enterprise Gateway.


You need to be consistent with FQN names or short server names.  


Still don't know how to get rid of the personal gateway turd.  

Super User
Super User

I'm thinking you should send this one to support. In service, click smiley icon in upper right and attach screen shot of the gateway being unavailable and explain that you have uninstalled the personal gateway.


You could also try installing the personal gateway on another box and once it shows up, in theory you should be able to refresh your data sources.

Follow on LinkedIn
@ me in replies or I'll lose your thread!!!
Instead of a Kudo, please vote for this idea
Become an expert!: Enterprise DNA
External Tools: MSHGQM
YouTube Channel!: Microsoft Hates Greg
Latest book!:
The Definitive Guide to Power Query (M)

DAX is easy, CALCULATE makes DAX hard...

As smoupre suggests, if you install the personal gateway somewhere else, PowerBI notices the change of hosts and is able to refresh the data sources. I did this yesterday and it succeeded.

JBeyer, no it doesn't. It should, but doesn't. I installled a personal gateway on my PC, then removed it completely. I've installed the Data Gateway on my Virtual Machine and successfully configured and added data source. I had access to the new gateway once for 10 seconds, now again it says that the personal is offline and I have no option to use the data gateway, as you can't select it. 

Sorry. There must be a misunderstanding. 

If i store my data as Excel files on Onedrive pro or Sharepoint and access it in PowerBI desktop wvia Get Data > Web (and have gone through the hurdle of finding the correct uri for my files) and Publish to the Power BI service, then:


On the PowerBI Service, after having edit the access to the sources (once) and Selected Schedule refresh etc then Scheduled Refresh works and refreshes the data every day for instance.


(This is with a Pro licence) 


I hope i did not misunderstand...

No offence man but you're replying to say you don't know.

If you don't have a solution or it's not effecting you, why would you reply?


I'm very aware of how to load data into Power BI. This thread has nothing to do with that. It has to do with the residual gateway that is affecting the new Data Gateway. And the new Gateway that IS setup is not accessable.



Did this get solved?  I've uninstalled (from control panel, no errors) the Personal Gateway.  I want to switch a data source (SQL Server DB) over to the Enterprise gateway now that it's available to me.  


I can't.  PowerBI still thinks my personal gateway is installed.  When will it "un-register" or forget it's there & allow me to use the Enterprise Gateway?


Screen Shot 2016-05-03 at 3.35.24 PM.png

@Evogelpohl I believe if you have access to the EG, the option to move should be there regardless of your personal gateway being online or not... Have you confirmed that the datasource you are using has been created in the EG, and that your user has been applied to that data source in the EG? Both those are prerequisites to being able to publish workbooks using the EG.

Looking for more Power BI tips, tricks & tools? Check out the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Thanks @Seth_C_Bauer for the follow up. 


Yes, under "manage gateways", I have confirmed that the SQL server hosting the DB that my PBIX queries is listed, with my credentials.  The PBIX refreshes fine on the desktop using my credentials.  The manage-gateway test-service says: "Online, You are good to go"


I still can't switch my PBIX data source over to the EG.


Yet & still - my personal gateway is still being referenced in the service.  Even if I could register this data source w/ the EG, it still seems like a bug that PowerBI is not aware that I've totally removed my Personal Gateway.  



@Evogelpohl Do me a quick favor. What happens when you create a new PBIX to the SQL data source in the same way as the other file (import/direct query) and just add a quick visual, publish to the Service. Does the new report/datasource use the EG? I want to see if the behavior is the same or if it works.

Looking for more Power BI tips, tricks & tools? Check out the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

@Seth_C_Bauer Good thoughts. Here's what I tried & the outcomes:

Built brand new PBIX, with same SQL Server & DB, published. Clicked on Sched-Refresh -> YES! I can choose between my (defunct, but still there) Personal GW or the Enterprise Gateway. Works.
So, we know that the gateway is alive & working for me.
Though - odd - it still thinks my PG is registered, but offline.

Opened the original PBIX:
Ensured that the queries reference the exact SQL server name & DB name (even making sure I'm not using FDQN in the PBIX, but just the hostname in the gateway settings), re-publish -> Same error, says my PG is offline, EG grayed out.

Opened the original PBIX:
Saved it as a different file entirely. Publish the duplicate -> Same error, says my PG is offline, EG grayed out.

Opened the original PBIX:
Completely remove all saved data sources - deleted them all from the PBID data source settings. Save. Refresh the PBIX in the PBID, re-connected to the SQL server, Publish -> Same error, says my PG is offline, EG grayed out.

Open a ticket with MS Support -> waiting on call.

Did you get this issue resolved? I've had the same issue for months and would love to know what the solution is.

+1, the same problem here.... thx!

I am getting exactley the same issue.

Not applicable

I also have same problem with personal gateway I can't remove from app.powerbi.service. And best part is, I am only testing so there is no special data source?

Hope this posts bring some attention from MS team to our problem.

I am still gettting the same issue. Are there any updates on this issue? @howtomicrosoft

Support have given this list of steps (assuming every one uses Powershell) to go through after Uninstall to make sure that the Gateway is removed:


Go to Powershell and run:

get-wmiobject win32_product | select name,identifyingnumber | where {$ -like "*data management*"}

This will return the GUID for the package. Then type the following:

msiexec /x '{GUIDforpackage}’


Also (if they exist) remove:





and remove the following folders

C:\Program Files\Power BI Personal Gateway

C:\Users\<user>\AppData\Roaming\Microsoft\Data Transfer

C:\Users\<user>\AppData\Local\Power BI Personal Gateway

C:\Users\<user>\AppData\Local\PowerBI Personal Gateway


in my view the last two lines above should be :

C:\Users\<user>\AppData\Local\Microsoft\Power BI Personal Gateway

C:\Users\<user>\AppData\Local\Microsoft\PowerBI Personal Gateway


However, this has not worked for me.


There is also this article, about the PBIEgwService  service


From <>


Net net, 4  and a half weeks  after cbeing in contact with support , i had a message yesterday from someone who undertsood the issue, so i am hopeful.



Not applicable

Thanks for that.


This is now beyond a minor annoyance for me too!!!


Just to reiterate to any MS people watchin this thread - the PC that had Personal Gateway installed DOES NOT EXIST ANY MORE SO I CAN'T UNINSTALL ANYTHING.


I'm now getting emails telling me that my PowerBI Service data refreshes failed because my Personal Gateway is off line....


This is very very wrong, becuase the Enterprise Gateway is Offline.....



Hi @Anonymous


For your issue could you not possibly go into the Dataset and change it from the current gateway to connect directly?


As well as potentially remove the schedule, so that you do not receive the emails due to there being no refreshing happening?

Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Power BI Blog


In the Service, the option to select between Gateway and Connect Directly is greyed unfortunately: i cannot change ; if you know how to allow that change, this would solve my issue.

@Evogelpohl Thanks for the detailed response. Yeah, that pretty much exhausts everything I can think of. Be sure to update this thread when/if they figure out what the problem was... I'll be interested in to hearing what it is.

Looking for more Power BI tips, tricks & tools? Check out the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.