Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

A new Data Days event is coming soon! This time we’re going bigger than ever. Fabric, Power BI, SQL, AI and more. Don't miss out.

Reply
guyhorn
New Member

How to get all ACTIVE Azure AD users

Hi. Active user is a user who logs-in. Do not confuse that with accountEnabled.

 

Azure AD reports that in the SigninLogs. 

 

I use this one now:

 

"set truncationmaxrecords=600000;SigninLogs | where Category == 'SignInLogs' | summarize count() by UserPrincipalName"

But i'm not sure it is any good. 

 

And the maxrecords seams only to work downwords. So I can ask for less records but not fot more. How can I increase the records number? I have 800K users to report.

5 REPLIES 5
lbendlin
Super User
Super User

No. I want to get all user's last login date. Therefore I need to get them all. I now founf the query: 

 

$signInQuery = $signInQuery = "set notruncation;SigninLogs | summarize count() by UserPrincipalName"

 

But even setting notruncationretrievs only 500000 users.  And I have 750000.

PS: this works and retrieve 30 records:\

 

$signInQuery = "set truncationmaxrecords=30;SigninLogs | summarize count() by UserPrincipalName"

With that amount of users you likely have subdomains. You could run separate queries for each subdomain and then concatenate.

No. For two reaons. I do have an Azure AD domain with almost a million users. But above all,AAD has no sub domains.

Helpful resources

Announcements
May Power BI Update Carousel

Power BI Monthly Update - May 2026

Check out the May 2026 Power BI update to learn about new features.

Fabric SQL PBI Data Days

Data Days 2026 coming soon!

Sign up to receive a private message when registration opens and key events begin.

New to Fabric survey Carousel

New to Fabric Survey

If you have recently started exploring Fabric, we'd love to hear how it's going. Your feedback can help with product improvements.

Power BI DataViz World Championships carousel

Power BI DataViz World Championships - June 2026

A new Power BI DataViz World Championship is coming this June! Don't miss out on submitting your entry.