Forum Discussion
guyhorn
3 years agoNew Member
How to get all ACTIVE Azure AD users
Hi. Active user is a user who logs-in. Do not confuse that with accountEnabled. Azure AD reports that in the SigninLogs. I use this one now: "set truncationmaxrecords=600000;SigninLogs |...
lbendlin
3 years agoSuper User
Do you mean user presence? User presence in Teams - Microsoft Teams | Microsoft Learn
guyhorn
3 years agoNew Member
No. I want to get all user's last login date. Therefore I need to get them all. I now founf the query:
$signInQuery = $signInQuery = "set notruncation;SigninLogs | summarize count() by UserPrincipalName"
But even setting notruncationretrievs only 500000 users. And I have 750000.
- guyhorn3 years agoNew Member
PS: this works and retrieve 30 records:\
$signInQuery = "set truncationmaxrecords=30;SigninLogs | summarize count() by UserPrincipalName"