Forum Discussion

guyhorn's avatar
guyhorn
New Member
3 years ago

How to get all ACTIVE Azure AD users

Hi. Active user is a user who logs-in. Do not confuse that with accountEnabled.

 

Azure AD reports that in the SigninLogs. 

 

I use this one now:

 

"set truncationmaxrecords=600000;SigninLogs | where Category == 'SignInLogs' | summarize count() by UserPrincipalName"

But i'm not sure it is any good. 

 

And the maxrecords seams only to work downwords. So I can ask for less records but not fot more. How can I increase the records number? I have 800K users to report.

5 Replies

    • guyhorn's avatar
      guyhorn
      New Member

      No. I want to get all user's last login date. Therefore I need to get them all. I now founf the query: 

       

      $signInQuery = $signInQuery = "set notruncation;SigninLogs | summarize count() by UserPrincipalName"

       

      But even setting notruncationretrievs only 500000 users.  And I have 750000.

      • guyhorn's avatar
        guyhorn
        New Member

        PS: this works and retrieve 30 records:\

         

        $signInQuery = "set truncationmaxrecords=30;SigninLogs | summarize count() by UserPrincipalName"