Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Helper V
Helper V

Refresh error time out



Since Saturday I'm having troubles refreshing my Power BI reports from the Service. 
If I update them with the Desktop I have no issues, but when I try to do it with the service (Scheduled or On demand) it keeps working for hours and then it crashes: 

"Timeout occurred when sending or receiving a request".

My Gateway is working fine, and does not show any error message. 

Any ideas why? 


Thank you in advance. 



Regular Visitor

Hi, I'm experiencing the same issue. The report was working perfectly and updating every 3 hours until last Friday. From then, it fails systematically to connect to Salesforce Reports. It's worth noticing that I have no problem to connect to Salesforce Objects (as I use both).


In the WebApp connectors authentication are all goor for SFDC Objects, and in error for Reports. When trying to reconnect with my SFDC credentials, they seem to be accepted but the authentication process get stuck with the looping dots until timeout.

In the Desktop App, everything good with SFDC Object just like on the WebApp, but the behavior is a bit different for the SFDC Reports connector. It seems to accept the authentication and shows the Reports list window. But then it loads it endlessly.


Here is the little track that I try to follow:

I think it's nothing to do with the actual authentication to SFDC, and may be related to the way Power BI processes the reports list brought back by SFDC Rest API. SFDC applied its latest release on August 15th. I can't see the exact date of the latest Power BI release. So it probably the SFDC Reports connector which changed or the SFDC REST API which changed the data format of the response.

In my case I have not a Salesforce connection, so I have submited a ticket because the problem persists....Smiley Sad

Frequent Visitor

I've been having the same issue since last Wednesday. One thing I've noted is that "Last Refresh Succeeded" reports as "null" for a number of hours until it finally times out.


Similar issue here:

Advocate I
Advocate I

I was having this problem too, and sometimes the error message said it was related to a certain query, other times to another query - both of them involved merging data from other queries.


I inserted a few Table.Buffer in the beginning and at the end of a few queries that were involved in the data merging, and it started refreshing in the service again.

Thank you for your reply @paulob_involves but the error doesn't reference to any query in particular, or at least I don't know where to look. 

Could you please develop a little bit more where you finded the error and how you solved it with some screenshots? Like that I'm going to be able to see if we are talking about the same case.

Thank you.

In the service (web), under dataset configurations you can click in Refresh History, for me it shows in the details the problematic table:

"Timeout expired. The timeout period elapsed prior to completion of the operation. Table: SF_fDataSales."


From there I went to Power Query, and in the query steps I edited the formula of one of the first steps of this table, including a Table.Buffer function. Then I did the same for one of the last steps.


But that's a weird solution for a weird issue, I was about to open a support ticket when this solved my problem, and I don't know why it worked. If you're on Pro license I'd advise you to open a support ticket instead.

where did you place these 2 buffers.  you said first steps and last steps.  Did you make it the first step and last step or after a specific step?



I have noticed this as well in the error logs. After doing a bit more research and troubleshooting, it seems as if this error is specific to cloud data sources. I was able to run a successful refresh in the service with a dataset containing non cloud data sources. Any dataset with a cloud datasource will experience this exact same issue.


I am assuming the table your error log was referencing was a Salesforce table (SF_fDataSales?). 


Thanks for suggestion on leveraging Table.Buffer. Will give that a shot and see what the outcome is.

Exactly, Salesforce data merged with a table stored in Sharepoint.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.