Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Bbrown44
Advocate II
Advocate II

RLS Configuration Issue

So I am trying to implement RLS using the documentation in the link below

https://docs.microsoft.com/en-us/power-bi/service-admin-rls

 

my 1st step was to create a bridge table as discuss in this youtube video (Guy in a Cube 1:54 seconds in)

 

https://youtu.be/9wN33rTaiB4

 

Here is the structure of my bridge tablestep a.JPG

 

my second step was to set Row Security on the bridge table see pic below

Step 1.JPG

 

3rd step was to set manage roles and set the Principal email as "userprincipalname()" see below

step 2.JPG

 

 

3rd step was to test manage roles in view see below:Step 3.JPG

 

 

When i completed that step the view worked as I can only see the school related to Charlela on the bridge table

step 4.JPG

 

 

So I publish up to my Power BI Pro service and update the app for distribution see steps belowstep 5.JPG

 

 

checked the app properties

step 6.JPG

 

 

made it accessable to my whole organization since the RLS will provide access via userprincipalname()

step 7.JPG

 

 

My final test was to see if Charlela could view her data via the app.

 

When she accessed the app she received this screenshot

step 8.jpg

 

 

I have no idea how to troubleshoot this now... PLEASE HELP!!!

~Bryon

 

1 ACCEPTED SOLUTION

It is true that RLS is now defined in the Desktop, but once defined in the Desktop and published to the service, you still have to assign users to the roles you created in the desktop

 

To get the the security option, navigate to your workspace, then datasets, select "...", the select Security

You should now see the role(s) you created, and from there you assign the users

 

2019-01-15_13-38-58.jpg2019-01-15_13-41-53.jpg

View solution in original post

12 REPLIES 12
blopez11
Resident Rockstar
Resident Rockstar

In the service, you need to assign users to the role you created

 

In the service, navigate to the dataset, then select the security option

You should see the role you created

Add users to the role

 

Good luck,

RLS is no longer a function in Power BI Service so the documentation is out of date. see snapshot in thread

It is true that RLS is now defined in the Desktop, but once defined in the Desktop and published to the service, you still have to assign users to the roles you created in the desktop

 

To get the the security option, navigate to your workspace, then datasets, select "...", the select Security

You should now see the role(s) you created, and from there you assign the users

 

2019-01-15_13-38-58.jpg2019-01-15_13-41-53.jpg

Thanks so much that worked!  Right now I am only setting security features for 12 users.  How would you set up a group of 1600 users?

issue 3.JPG

 

@Bbrown44 I'm sorry, but I can't see it.

 

RLS is no longer a function in Power BI Service so the documentation is out of date.issue 3.JPG

 

 

 

Ok, I just tried and it worked. I am sorry, but I don't what is happening to your dataset. 

 

Cheers

 

I don't see this fuction in Power BI Desktop for secruity... Also I am using 22 different tables in my model which one would I set security on?

Hello @Bbrown44,

 

First question, is your RLS right? I mean, the role is working as it should? 

 

Second, the step @blopez11 mentioned is on Power BI service.

 

Cheers

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.