Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
AGo
Post Patron
Post Patron

Postgresql gateway failure

Hi!

With new update I thought Npgsql was no longer mandatory, but it seems to be if connecting with the gateway, so I followed the old path as always.

Updated .NET to last version 4.8 and installed Npgsql with GAC version 4.1.3. When adding datasource to gateway cluster I've got returned this error: The installed database provider 'Npgsql' targets an incompatible .NET Framework. Please install Npgsql version 4.0.10.0 or earlier.

 

Does this version combo of .NET and Npgsql has some problem. What versions should I use?

Thanks

1 ACCEPTED SOLUTION

It's now working with npgsql (4.0.10 and GAC) downgrade, hope it will be fixed soon with a full implementation of the ADO .NET data provider in the gateway.

View solution in original post

9 REPLIES 9
bob32
Frequent Visitor

I reinstalled Npgsql but this time making sure to select "GAC Installation" and it appears to be working now

bob32
Frequent Visitor

I have the same issue (4.0.9 is installed). I installed PBI Desktop on the gateway server and connected to the same Postgres server without issue (with the same user)

@bob32 can you try installing precisely version 4.0.10.0 and tell me if it solves the problem?

bob32
Frequent Visitor

@AGo I tried v4.0.10 already (the git tag/package does not specify another level of versioning, so I'm not sure if that is actually the *exact* version to which you refer) and it was the same error

Ok, thanks for your information, I hope someone from Microsoft can help us.

v-lionel-msft
Community Support
Community Support

Hi @AGo ,

 

"The installed database provider 'Npgsql' targets an incompatible .NET Framework. Please install Npgsql version 4.0.10.0 or earlier."

Please install Npgsql version 4.0.10.0 or earlier.

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

That's what I did: installed Npgsql version is 4.1.3

Hi @AGo ,

 

Please create support ticket .

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It's now working with npgsql (4.0.10 and GAC) downgrade, hope it will be fixed soon with a full implementation of the ADO .NET data provider in the gateway.

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors