Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
Anonymous
Not applicable

Custom connector not showing when configuring gateway in PowerBI Service

Hi community,

 

I have developed a custom connector which I tested in PowerBI Desktop. I also managed to publish to the PowerBI Service and schedule a refresh using a personal gateway. So far everyting works fine. Trouble starts when I try to configure a refresh using a standard gateway as described here: https://docs.microsoft.com/en-us/power-bi/connect-data/service-gateway-custom-connectors

 

I have a On-premises data gateway (version 3000.106.11) running on my computer, placed my connector file (.mez) in the right folder, and it's showing up in the gateway:

Capture1.PNG

 

I can also connect to my gateway in PowerBI Service, but when I want to add a new data source to it, my custom connector is not showing in the dropdown:

Capture2.jpg

 

Some help will be much appreciated.

1 ACCEPTED SOLUTION
Anonymous
Not applicable

The issue has been resolved. The problem was with the implementation of the TestConnection method in the connector code. The main method of the connector had 2 parameters of type Date. I changed them to type text and changed the TestConnection method from:

TestConnection = (dataSourcePath) => 
	let
		params = Json.Document(dataSourcePath),
		startDate = Date.FromText(params[startDate]),
		endDate = Date.FromText(params[endDate])
	in
		{"MyConnector.Data", startDate, endDate}

to:

TestConnection = (dataSourcePath) => 
	let
		params = Json.Document(dataSourcePath),
		startDate = params[startDate],
		endDate = params[endDate]
	in
		{"MyConnector.Data", startDate, endDate}

and now I can select my connector in PowerBI service.

View solution in original post

10 REPLIES 10
Anonymous
Not applicable

The issue has been resolved. The problem was with the implementation of the TestConnection method in the connector code. The main method of the connector had 2 parameters of type Date. I changed them to type text and changed the TestConnection method from:

TestConnection = (dataSourcePath) => 
	let
		params = Json.Document(dataSourcePath),
		startDate = Date.FromText(params[startDate]),
		endDate = Date.FromText(params[endDate])
	in
		{"MyConnector.Data", startDate, endDate}

to:

TestConnection = (dataSourcePath) => 
	let
		params = Json.Document(dataSourcePath),
		startDate = params[startDate],
		endDate = params[endDate]
	in
		{"MyConnector.Data", startDate, endDate}

and now I can select my connector in PowerBI service.

v-rongtiep-msft
Community Support
Community Support

Hi @Anonymous ,

Please refer to the following topic to see if it helps you.

https://community.powerbi.com/t5/Service/Configuring-custom-connector-in-Power-BI-service/m-p/1644240

 

1) First of all uninstalled "Personal mode" gateway and installed "Standard mode" gateway

2) Went to services -> On-premise data gateway service->Properties ->Log on-> Select Local System Account and check box "Allow Service to interact with desktop"

3) Went to Gateway -> Connectors tab -> Pasted the location where custom connector file is residing

4) Restarted the gateway

 

Best Regards

Community Support Team _ Polly

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

v-rongtiep-msft
Community Support
Community Support

Hi @Anonymous ,

Please ensure the connector is certified.A certified connector is:

  • Built by the developer
  • Evaluated by Microsoft
  • Distributed by Microsoft
  • Maintained by the developer
  • Supported by the developer

This program will allow owners of data sources to deliver connectors seamlessly via Get Data in Power BI, making it easy for you to take advantage of the capabilities of Power BI and the breadth of our audience.

 

And please refer to the following topic to see if it helps you.

https://community.powerbi.com/t5/Power-Query/Enterprise-gateway-custom-connector-not-available/td-p/558305

 

Best Regards

Community Support Team _ Polly

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Do I need to have my connector officially certified to work with the enterprise gateway? I thought by using a gateway I didn't have to go through the certification process and just use the connector internally in our organization.

Hi @Anonymous ,

Please refer to the following document for more information.

https://powerbi.microsoft.com/pt-br/blog/announcing-general-availability-of-custom-and-certified-connectors-for-power-bi/

Please try the topic steps to see if they help you.

https://community.powerbi.com/t5/Power-Query/Enterprise-gateway-custom-connector-not-available/td-p/558305

 

Best Regards

Community Support Team _ Polly

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

If I understand the document you posted correctly, custom connectors should be fully supported in the enterprise gateway and PowerBI service without certification.

 

As for the other topic, the problem doesn't seem te be with the gateway itself. I have the latest version installed and I can see my custom connector in the gateway. It's just not showing up in PowerBI Service.

nitishsh91
Solution Supplier
Solution Supplier

Hi @Anonymous 

 

Please make sure you have the below setting checked in on gateway settings of your cluster

 

nitishsh91_0-1639159336583.png

 

This should allow to use custom data sources.

Anonymous
Not applicable

I already had the "Allow user's custom data connectors..." setting checked, and I also tried with the other 2 settings checked, but unfortunately it's still not showing in the dropdown.

Did you restart On-Premises gateway service after adding custom connector?

Check out below link also:

 

https://support.biconnector.com/support/solutions/articles/8000074097-bi-connector-does-not-show-up-...

Anonymous
Not applicable

Yes I did restart it.

 

At first I thought maybe it had something to do with with access rights on my computer. So I tried putting the connector file in different folders and using different service accounts for the gateway. But still no luck.

 

I also tried the solution to this post: https://community.powerbi.com/t5/Service/Configuring-custom-connector-in-Power-BI-service/m-p/164424.... But that doesn't work either for me.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

Top Solution Authors