Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
jcollinson2001
Resolver IV
Resolver IV

Test Connection Broken

Hi,

 

I've been setting up Kerberos authentication and changing the service account running PBIRS. Now when I click "Test Connection", from the Data Sources screen of report managment, it fails every time, even though the credentials are correct and the report is actually able to connect just fine. 

 

We only use either direct query (to SQL Server) or analysis services as our data sources...

 

For direct query, I just get a popup saying something's broken, and looking under the hood the HTTP request that is sent (when the Test Connection button is pressed) returns a HTTP 500.

 

For Analysis services, I get the error message "Data source AnalysisServices is not supported.".

 

Please can someone help?

 

Thanks

14 REPLIES 14
Arez2017
Helper I
Helper I

I have the same issue with March 2018.

 

Is that a bug? Is there any fix for it please?

 

Is it due to Microsoft security update? It works when I installed MArch 2018 but now it is not working which is a weird behaviour

 

Thanks

Asma

Coming back to this one.. I'm no longer seeing the issue in August 2018 update. 

 

Is the issue resolved for everyone else who has upgraded?

 

 

I am still facing it with Aug 18 release. It's kind of strange, the report works allright but the connection test always runs into cannot connect datasource....

 

Hi,
the update did not solve this problem.
We have done a deinstallation and new Installation of the updatet version.
This solve the Problem for us.

AngusF
Regular Visitor

Also being affected by this issue testing connection to SSAS sources using "as the user viewing the report". It was working previously. Would love to see this resolved in the next update for the March release - any acknowledgement from MS on this one ?
GDAN
Frequent Visitor

Hi,
we have the same issue since  PowerBI-Server update from March2018.

Only for the Power BI Reports.

We have the same issue. We have a report published to the server with SSAS Tabular 2016 in Direct Query mode as the data source. The SSAS Tabular model in turn has a Direct Query connection to the underlying SQL Server DB, where we are applying user based row level security. The report was working fine until this weekend, although I did notice the "Data source AnalysisServices is not supported." message when I clicked on Test Connection. Now the report has stopped working completely. I have tested this with some of the end users and have established the following:

 

- They are able to connect to the SSAS cube as expected via Excel, and can view the data they are supposed to (i.e. everything is working properly)

- When they try and view the report in PBI Report Server, the report opens but each of the visuals fails with an error message saying they have insufficient permissions

- I tried creating a completely new report using PBI Desktop on one user's own machine, with the SSAS cube as the data source. He was able to connect to the cube but again got a permissions error when trying to view any of the data in PBI Desktop.

 

Has there been any update from Microsoft on this? The report is business critical and I don't have a viable solution at this point.

 

jcollinson2001
Resolver IV
Resolver IV

Discovered this is a permissions issue on the ReportServer database. I changed the service account running PBIRS, and after elevating permissions on this account in the ReportServer database, the problem goes away.

 

I'm still keen to understand why this has happened and what permission the account actually needs (as I've probably elevated permissions far too high).

 

Any input from anyone appreciated.

 

Thanks 🙂

OK, permissions only partly solved the issue. I've now consolidated the issue as:

 

  • Open report management screen, click on data sources, for a report that connects to SSAS (all others are fine) with authentication set to "as the user running the report"
  • Click Test Connection, get the error stating "Data source AnalysisServices is not supported."
  • Look in Chrome dev tools, the API call to Model.CheckDataSourceConnection returns an error
  •  Change the connection and enter explicit credentials, click Test Connection with success
  •  Look in Chrome dev tools, the API call is now going to Model.CheckConnection
  •  Change the connection back to "as the user running the report", click Test Connection with success
  • Look in Chrome dev tools, the API call is still going to Model.CheckConnection

 

I draw the conclusion that this is an issue with Report Server. Please can someone from MS confirm.

 

Thanks

I have the same issue.

 

A Power BI report with 'live connection' to SSAS MD with Kerberos ('As the user viewing the report'). The report is working!

 

But if I go to 'Manage > Data sources' and test the connection i get "Data source AnalysisServices is not supported. "

 

Regards Taico

 

Hi Taico,

 

Thanks for posting your experience. If you change from "As the user viewing the report" to "Using the following credentials", then straight back to "As the user viewing the report" and test the connection, does it work?

 

Thanks

It does initially.

 

But if I leave the "Manage > Data sources" and return and test again it goes back to "Data source AnalysisServices is not supported."

 

Regards Taico

Hello

 

Yes I trie this and it works so it this a bug? I am using SSRS MArch 2018

 

Many thanks

Asma

For sure - this is exactly the same for me here.

 

If you monitor the HTTP requests being sent when you Test Connection, you can probably see that a different part of the ReportServer API is being called. The first press calls one method (which fails), when you change the connection type it triggers a different method to be called (which succeeds). If you navigate off the page and back to it, then the failing method is called again.

 

Hope that someone from MS will pick this thread up and confirm this as a bug.

 

All the best.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.