Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Progress Database 10713 error

I am able to connect to my ODBC database and I can pull in some of the tables OK. However, most of the tables are giving me the following error and will not open:

 

DataSource.Error: ODBC: ERROR [HY000] [DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Syntax error in SQL statement at or about "'pt_program' AND sysprogress.sysindexes." (10713)

 

Is there a solution for this?

1 ACCEPTED SOLUTION
v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Based on my research, the issue should be caused by a logic error in the ODBC SQLPrimaryKeys function which mistook the underscore (_) character as a wildcard and returned an incorrect query string (missing an operator such as the equals sign or LIKE) to the caller. Please try to update the to 11.6.3 and version 7.10.06.175 of the Progress OpenEdge ODBC driver. See: Cannot call catalog for tables with an underscore in table name.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Based on my research, the issue should be caused by a logic error in the ODBC SQLPrimaryKeys function which mistook the underscore (_) character as a wildcard and returned an incorrect query string (missing an operator such as the equals sign or LIKE) to the caller. Please try to update the to 11.6.3 and version 7.10.06.175 of the Progress OpenEdge ODBC driver. See: Cannot call catalog for tables with an underscore in table name.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Thank you so much. I will have my IT department update the driver and try again.

Did updating the version of the driver resolve this issue? i am currently coming across the same problem here

Anonymous
Not applicable

I am finding the same problem

Helpful resources

Announcements
Fabcon_Europe_Social_Bogo

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors
Top Kudoed Authors