Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

Progress Database 10713 error

I am able to connect to my ODBC database and I can pull in some of the tables OK. However, most of the tables are giving me the following error and will not open:

 

DataSource.Error: ODBC: ERROR [HY000] [DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OPENEDGE]Syntax error in SQL statement at or about "'pt_program' AND sysprogress.sysindexes." (10713)

 

Is there a solution for this?

1 ACCEPTED SOLUTION
v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Based on my research, the issue should be caused by a logic error in the ODBC SQLPrimaryKeys function which mistook the underscore (_) character as a wildcard and returned an incorrect query string (missing an operator such as the equals sign or LIKE) to the caller. Please try to update the to 11.6.3 and version 7.10.06.175 of the Progress OpenEdge ODBC driver. See: Cannot call catalog for tables with an underscore in table name.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Based on my research, the issue should be caused by a logic error in the ODBC SQLPrimaryKeys function which mistook the underscore (_) character as a wildcard and returned an incorrect query string (missing an operator such as the equals sign or LIKE) to the caller. Please try to update the to 11.6.3 and version 7.10.06.175 of the Progress OpenEdge ODBC driver. See: Cannot call catalog for tables with an underscore in table name.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Thank you so much. I will have my IT department update the driver and try again.

Did updating the version of the driver resolve this issue? i am currently coming across the same problem here

Anonymous
Not applicable

I am finding the same problem

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors