Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

July 7 - July 17 | Round 2 of the Power BI Dataviz World Championships. Don't miss your chance! Learn more

Reply
VaibhavBhosle
New Member

KQL embedded in Power Query to query Defender Log through Advanced Hunting

let
AdvancedHuntingQuery = "
DeviceTvmSoftwareVulnerabilitiesKB
| where VulnerabilitySeverityLevel == "High"
",
HuntingUrl = "https://api.securitycenter.microsoft.cxxxxxxxxxxxxxxxx",
Response = Json.Document(Web.Contents(HuntingUrl, [Query=[key=AdvancedHuntingQuery]])),
TypeMap = #table(
{ "Type", "PowerBiType" },
{
{ "Double", Double.Type },
{ "Int64", Int64.Type },
{ "Int32", Int32.Type },
{ "Int16", Int16.Type },
{ "UInt64", Number.Type },
{ "UInt32", Number.Type },
{ "UInt16", Number.Type },
{ "Byte", Byte.Type },
{ "Single", Single.Type },
{ "Decimal", Decimal.Type },
{ "TimeSpan", Duration.Type },
{ "DateTime", DateTimeZone.Type },
{ "String", Text.Type },
{ "Boolean", Logical.Type },
{ "SByte", Logical.Type },
{ "Guid", Text.Type }
}),
Schema = Table.FromRecords(Response[Schema]),
Results = Response[Results],
Rows = Table.FromRecords(Results, Schema[Name])
in
Rows

1 ACCEPTED SOLUTION
Expiscornovus
Most Valuable Professional
Most Valuable Professional

Hi @VaibhavBhosle,

 

To be clear, your question is how to use KQL queries in your Power Query, correct?

 

If that is the case I would suggest to have a look at a couple of Microsoft examples.

 

I found the below is example in the Azure Data Explorer connector documentation. It demonstrates how you could use a function for your KQL queries and use those in your Power Query M.

 

The example is from a different type of data source, but in concept you should be able to use the same for your setup.

 

https://learn.microsoft.com/en-us/power-query/connectors/azure-data-explorer#provide-parameters-to-a...

 



Happy to help out 🙂

I share #PowerAutomate and #SharePointOnline content on my Blog, Bluesky profile or Youtube Channel

View solution in original post

2 REPLIES 2
VaibhavBhosle
New Member

Thanks @Expiscornovus  much appreciated.

 

Expiscornovus
Most Valuable Professional
Most Valuable Professional

Hi @VaibhavBhosle,

 

To be clear, your question is how to use KQL queries in your Power Query, correct?

 

If that is the case I would suggest to have a look at a couple of Microsoft examples.

 

I found the below is example in the Azure Data Explorer connector documentation. It demonstrates how you could use a function for your KQL queries and use those in your Power Query M.

 

The example is from a different type of data source, but in concept you should be able to use the same for your setup.

 

https://learn.microsoft.com/en-us/power-query/connectors/azure-data-explorer#provide-parameters-to-a...

 



Happy to help out 🙂

I share #PowerAutomate and #SharePointOnline content on my Blog, Bluesky profile or Youtube Channel

Helpful resources

Announcements
FabCon and SQLCon Barcelona 2026

FabCon & SQLCon – Barcelona 2026

Join us in Barcelona for FabCon and SQLCon, the Fabric, Power BI, SQL, and AI community event. Save €200 with code FABCMTY200.

60 days of Data Days Carousel

Data Days 2026

Join Fabric Data Days 2026: 60 days of free live/on-demand sessions, challenges, study groups, and certification opportunities.

Power BI DataViz World Championships carousel

Power BI DataViz World Championships - June 2026

A new Power BI DataViz World Championship is coming this June! Don't miss out on submitting your entry.