Forum Discussion
VaibhavBhosle
1 year agoNew Member
KQL embedded in Power Query to query Defender Log through Advanced Hunting
let AdvancedHuntingQuery = " DeviceTvmSoftwareVulnerabilitiesKB | where VulnerabilitySeverityLevel == "High" ", HuntingUrl = "https://api.securitycenter.microsoft.cxxxxxxxxxxxxxxxx", Response =...
- 1 year ago
Hi VaibhavBhosle,
To be clear, your question is how to use KQL queries in your Power Query, correct?
If that is the case I would suggest to have a look at a couple of Microsoft examples.
I found the below is example in the Azure Data Explorer connector documentation. It demonstrates how you could use a function for your KQL queries and use those in your Power Query M.
The example is from a different type of data source, but in concept you should be able to use the same for your setup.
VaibhavBhosle
1 year agoNew Member
Thanks Expiscornovus much appreciated.