Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

July 7 - July 17 | Round 2 of the Power BI Dataviz World Championships. Don't miss your chance! Learn more

Reply
PG03
Frequent Visitor

Log Analytics Data Missing

I'm creating a report based on a simple Log Analytics query

 

SigninLogs
| where AppDisplayName startswith "Windows Sign In"
| where CreatedDateTime >= ago(7d)

 

This query returns 87,702 records.

 

When I use the "Export to Power Bi" feature in log analytics, paste the K code into a new blank query and collect the count of records I only get  50,192 records.

 

I've tried adjusted the "ago" to longer and shorter and each time it doesn't return the same amount of data.

 

Confrimed well within the API limits. 

 

Not sure if this is a Power Bi problem or Log Analytics API problem.

 

Any thoughts?

 

1 ACCEPTED SOLUTION
PG03
Frequent Visitor

I figured out the problem.  In the query I was projecting a column that was a JSON record.  Removing this column from the query normalized the results.

View solution in original post

3 REPLIES 3
PG03
Frequent Visitor

I figured out the problem.  In the query I was projecting a column that was a JSON record.  Removing this column from the query normalized the results.

parry2k
Super User
Super User

@PG03 are you exporting from Power BI or exporting to Power BI, not fully clear where you are exporting to/from?



Subscribe to the @PowerBIHowTo YT channel for an upcoming video on List and Record functions in Power Query!!

Learn Power BI and Fabric - subscribe to our YT channel - Click here: @PowerBIHowTo

If my solution proved useful, I'd be delighted to receive Kudos. When you put effort into asking a question, it's equally thoughtful to acknowledge and give Kudos to the individual who helped you solve the problem. It's a small gesture that shows appreciation and encouragement! ❤


Did I answer your question? Mark my post as a solution. Proud to be a Super User! Appreciate your Kudos 🙂
Feel free to email me with any of your BI needs.

PG03
Frequent Visitor

I'm using the Log Analytics "export" command to generate the M query

export.jpg

Helpful resources

Announcements
FabCon and SQLCon Barcelona 2026

FabCon & SQLCon – Barcelona 2026

Join us in Barcelona for FabCon and SQLCon, the Fabric, Power BI, SQL, and AI community event. Save €200 with code FABCMTY200.

60 days of Data Days Carousel

Data Days 2026

Join Fabric Data Days 2026: 60 days of free live/on-demand sessions, challenges, study groups, and certification opportunities.

Power BI DataViz World Championships carousel

Power BI DataViz World Championships - June 2026

A new Power BI DataViz World Championship is coming this June! Don't miss out on submitting your entry.