Forum Discussion
PG03
4 years agoFrequent Visitor
Log Analytics Data Missing
I'm creating a report based on a simple Log Analytics query
SigninLogs
| where AppDisplayName startswith "Windows Sign In"
| where CreatedDateTime >= ago(7d)
This query returns 87,702 records.
When I use the "Export to Power Bi" feature in log analytics, paste the K code into a new blank query and collect the count of records I only get 50,192 records.
I've tried adjusted the "ago" to longer and shorter and each time it doesn't return the same amount of data.
Confrimed well within the API limits.
Not sure if this is a Power Bi problem or Log Analytics API problem.
Any thoughts?
I figured out the problem. In the query I was projecting a column that was a JSON record. Removing this column from the query normalized the results.