Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Fab57
Frequent Visitor

can not publish to web due to disable block public internet first

Hello everyone,

I have a big problem with my web publication, and I can't find the solution. I'm an admin, I have the 'Publish to Web' option enabled, but I get an alert saying, "To enable Publish to Web, you need to disable Block Public Internet Access first." When I go to this option it's grayed out, and in any case it's disabled. I can't publish any of my reports on the web, and I can't find any solution. Can someone help me?

Capture d’écran 2023-07-23 à 22.04.40.pngCapture d’écran 2023-07-23 à 22.05.00.png

1 ACCEPTED SOLUTION
foodd
Super User
Super User

Hello @Fab57 ,

 

Begin with ensuring the two settings in the screenshot are set as they are highlighted and 
indicates that you want both sliders to be moved to the RIGHT. 

 

  • Publish to the web from your screenshot is already set to enabled.
  • Choose how embed codes work will change from
    • 'Allow only existing codes'
      to
    • 'Allow existing and new codes' When you move the slider to the RIGHT. 

Start with this, and reply if you are successful or need additional assistance.

foodd_0-1690144355570.png

 

View solution in original post

5 REPLIES 5
Fab57
Frequent Visitor

I feel so stupid...I just never try to slide the second one to the right...😳

Thank you so much @foodd 

Wow, sliding the slider to the right works fine 😀

Awesome!  If this has solved the issue, please mark it as a Solution, and apply Kudos.

foodd
Super User
Super User

Hello @Fab57 ,

 

Begin with ensuring the two settings in the screenshot are set as they are highlighted and 
indicates that you want both sliders to be moved to the RIGHT. 

 

  • Publish to the web from your screenshot is already set to enabled.
  • Choose how embed codes work will change from
    • 'Allow only existing codes'
      to
    • 'Allow existing and new codes' When you move the slider to the RIGHT. 

Start with this, and reply if you are successful or need additional assistance.

foodd_0-1690144355570.png

 

So, you don't need to actually disable Block Public Internet Access? Or does that step need to come before enabling these two Publish to Web settings?

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors