Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
gracerashmi
Helper I
Helper I

User access issue

Hi Team,

 

We are using the free trial license and i have published a Report but uCapture.JPGsers are not able to view the Report.

1 ACCEPTED SOLUTION

@gracerashmi

 

If you want a role that grant access to everything here is how to do it : 

 

Create a calculated column on your role table 

AllAccess = 1

Like that, you are going to have a column full of 1

 

Then add new role AllAccess, and then in the Table filter DAX expression type [AllAccess]=1

Then add concerned user by this role

 

- Quentin

View solution in original post

8 REPLIES 8
quentin_vigne
Solution Sage
Solution Sage

Hi @gracerashmi

 

There is two possible issues : 

 

1 - Only pro user can share a report online. Only pro user can see shared reports online.

2 - You are using DirectQuery without Gateway

 

- Quentin 

i have enabled the report in a workplace group. others are able to see the dashboard but 3 new persons in the group are facing this issue

@gracerashmi

 

There is maybe a Row Level Security blocking them from accesing the data ? 

 

- Quentin

Yes Role wise security is there but these 3 users has to be enabled without the security to view all. Can you help me on this.

@gracerashmi

 

So the 3 new users are not added to the RLS ? 

If you want to enable it for them you need to add their USERPRINCIPALNAME() to the RLS of PowerBI Desktop and add the same condition than other users or if you want to restrict their access, add condition when typing the code

 

- Quentin

RLS is created on a department. but this  3 users shouldnot have any filter on the department and they should see all. how do i do that.

@gracerashmi

 

If you want a role that grant access to everything here is how to do it : 

 

Create a calculated column on your role table 

AllAccess = 1

Like that, you are going to have a column full of 1

 

Then add new role AllAccess, and then in the Table filter DAX expression type [AllAccess]=1

Then add concerned user by this role

 

- Quentin

Thank you it worked

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors