Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

Replace Report and Dataset in Dev step from Deployment Pipeline


I have been trying the new DeployPipelines to improve deployment strategy.

And I ran into a limitation I don't seem to overcome.


I want to be able to set up my Deployment scenario like this:

- Setup a pipeline like Dev, Stage, Prod where is start from Prod and deploy to previous stages because Prod is already available, shared and RLS roles are already assigned to users
- Store my pbix-files in OneDrive (to have at least some version history)
- Publish my (existing) Reports in 'Dev' from OneDrive by using "Get Data" in and select my pbix-file from OneDrive (replacing the ones that came from Prod)
- Deploy to Stage and Prod


However, when I publish an already available report+dataset  from OneDrive to the Dev-workspace I get a duplicate in the Dev-workspace, even when the name is excactly the same as the one that's in the workspace.  I also tried to leave the Dev workspace empty and Published the report+dataset but than the compare shows "new" items in stead of "changed" ones. I really don't want to re-share the reports and/or hand out all the RLS roles again.


Any ideas how to accomplish this? 


Thanks in advance


Advocate I
Advocate I

We are doing the same process as @Jacco.  I agree, we want the OneDrive sync to work without duplicating reports when using deployment pipelines.  Was something ever figured out? 

If you already have a workspace in Dev stage and you want to connect it to OneDrive, please do that.

After you do and the reports are synced with OneDrive, please unassign the Dev workspace and assign it back. this will trigger the matching of items between dev and Test based on their display names, which should solve your problem.

I am currently having the same problem with replacing a dataset and report from our Test workspace to Prod workspace using the deployment pipeline.

I have NO problem Dev to Test, but then when I deploy to Prod, we get two reports and two datasets with the same names.  This then causes issues with the Link for the App.  I know which is the old vs new because of date and time stamps on the report and dataset.  I cannot figure out what the issue is and why this is happening.  I've searched many topics on pipelines and datasets, but this case is the closest to my issue I'm having.  My steps are

1) take pbix from desktop, dataset points to Dev tables

2) deploy dataset and report (which are named the same) and deploy to Dev on the Service.

3) in the pipeline, select the dataset and report (we have many other reports and datasets in this Workspace currently), select Deploy to Test.  No errors occur.

4) deployment to Test goes great, NO issues.  But before we do this, we use the Rules to change the database to test tables.  We refresh the dataset to look at Test server and Test database tables.

5) make sure that the Test report opens and loads data.  All is good.

6) go to pipeline, select the report and dataset in Test, select the Deploy to Prod.  No errors occur.

7) We also have Rules set up on this dataset to look at Prod server and Prod database tables.

😎 When I go back into the Workspace, I see duplicate report and duplicate dataset.  The only way I know which is which is because of the dates and time stamp on the new just deployed report and dataset.

Why is this happening.  The reason for deploy from Dev - Test - Prod is because of changes, enhancements, and new data in report.  This did not happen before.  BUT, just in the last week, I've had this happen on another Workspace and then realized after I deleted the old report and old dataset, that when you Update App, it changes the link to your report.  And the people call me that they get an error about the url.  So, deleted the old dataset and report is not a good solution.  I do not know how to workaround this issue or if it is a BUG.  any help would be grateful.

Not applicable

Hi @Jacco ,


Could you pls provide me some screenshots about your issue?


Best Regards,
Did I answer your question? Mark my post as a solution!

hi @Anonymous 


I created some screenshots of the process of Creating the Pipeline for an already published workspace, Deploy to previous stages and Publish the Report(s) from onedrive.

As a result of the publish from Onedrive (Get Data, Select pbix-files, Connect) I expect the corresponding report to be replaced. but as you can see in the last two screenshots, a duplicate is created.


I hope this helps in understanding my question


Best Regards




deploy to previous stage


Reports deployed succesfully


(re)Deploy  existing report to Test-env. by selecting get data and selecting the pbix-file from Onedrive





Duplicates of the report and the dataset are created instead of replaced.

as also the compare in the pipeline indicates


Looks like it's a known bug with OneDrive, unrelated to pipelines.

a workaround that might work:

1. 'get data' from the dev WS

2. 'Files'

3. instead of 'OneDrive', click 'Local file'.

4. Go to your OneDrive folder thorugh the local file system, and choose the same PBIx you wanted to upload.


Please let us know if after following these steps, it override the report+ dataset as intended.

Hi @Nimrod_Shalit ,


do you know where this known bug is registered and/or when it will be fixed?


Best regards


Hi @Nimrod_Shalit ,


thanks for looking into this.

What you're describing would work as a workaround from a functional point of few, but unfortunately not from a process point of few since I have business users changing the reports that just need to change and save it without worrying about the need to republish after each change they do.

the margin for error increases by 400% or more in my situation 😉 


any idea if and when this one-drive bug will be repared?

(and where I can find it to follow the bug)


best regards


Not applicable

Hi  @Jacco ,


I followed your steps but got a different result.

First I assigned a workspace in "Production",then by "deploy to previous stage">"Developement";

Then "go to developement workspace",I get the data from local .pbix file,and I got a notification as below:

Annotation 2020-07-03 172319.png

I select "replace it" and showing:


Could you pls test:if you get data from local file,not onedrive,will this issue still exist?In my test,I get the same .pbix file from local.


Best Regards,
Did I answer your question? Mark my post as a solution!

Hi @Kelly ,


When I "Get Data" from OneDrive .pbix-file (Either 'OneDrive for Business' or 'Workpace Onedrive'), my problem duplicating the report+dataset comes up.


When I "Get Data" from Local File .pbix-file I am getting the same result that you are experiencing, but that's not what I prefer, because it adds a lot more complexity and discipline to the process, since my business users need to be able to change the report without having to republish the report. I might be a workaround, but it's not something I want.


best regards



Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.