Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
TasosIoannou
Regular Visitor

Query does not refresh

Hello everyone, 

 

I have created a query which I was refreshing, on a daily basis, with no problems for months now. My source file is located in my company's G drive folder. I have to say at this point that when I was creating the query my option for getting data was "from excel file"...I have done some research and maybe this is the reason, however, there was no problem in refreshing my query so far up uintil yesterday. 

 

So when I press the "Refresh" buttton the query starts refreshing normally and gets stuck in this stage (see screen shot below). I get no error, and when I am refreshing every single table on its own everything works out perfectly with no issues or errors. 

 

TasosIoannou_0-1667487909508.png

I tried to refresh the query from the web interface but I get the following error (see screen shot) 

 

TasosIoannou_1-1667488032402.jpeg

So, scheduled refresh (or refresh from the web in my case is disabled due to data credentials). When I go to: Settings -- > Datasets -- > Data Source Credentials -- > Edit Credentials (see screen shot)
TasosIoannou_2-1667488084555.jpeg
the only option I get is "Windows without Impersonation" and If I choose "Organizational" in the Privacy Level of the Data Source menu (just below) and --> "Sign in", the whole thins gets stuck and tries to Sign in perpetually...It stays like this...
TasosIoannou_3-1667488116073.jpeg

 

 
Any ideas to get out of this conundrum? Would it maybe worth trying to move the source file to a sharepoint folder instead of the company's G drive which is located at  the moment? This could fix the updating from the web interface. But why is my model not refreshing when I hit the refresh button? And all out of a sudden, while each individual components of the qeury refresh on their own with no issues? 
 
Looking forward to your answers!
 
Tasos Ioannou
1 ACCEPTED SOLUTION

Hello @GilbertQ , 

 

This was a very weird issue...for some reason Power BI had created an extremely complex assosciation network between my tables which was so complex that had sent my whole query into an infinite loop. This was the reason that the query was not getting refreshed. 

 

I eventually deleted all these assosciations and just run the query again and it finally worked. 

 

Before doing that I had moved all the source files to a sharepoint folder. 

 

Thank you very much for your advice. 

View solution in original post

6 REPLIES 6
TasosIoannou
Regular Visitor

Hello @GilbertQ 

 

I did just that but the query still has the same behavior. 

 

TasosIoannou_0-1667828411611.png

I get no error, I can update tables one by one....but when I press the "Refresh" button...it just doesnt work...

Hi @TasosIoannou 

 

Can you confirm you have got the latest version of Power BI Desktop installed?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Hello @GilbertQ , 

 

I have this version installed: Version: 2.110.1085.0 64-bit (October 2022)

 

It shoul db efairly updated, I presume. I have a meeting with one of my company's data engineer to try and troubleshoot this issue. If we hopefully find the reason this is happening I will update the thread... 

 

If not, I will let you know and we can try to get new ideas as to why this is happening. Thank you very much for the effort and consideration!

GilbertQ
Super User
Super User

Hi @TasosIoannou 

 

I would suggest putting into a SharePoint online folder then you would not need a gateway to refresh the data.

 

If you are going to a local G: Drive then maybe try using the Windows authentication?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Hello @GilbertQ , 

 

This was a very weird issue...for some reason Power BI had created an extremely complex assosciation network between my tables which was so complex that had sent my whole query into an infinite loop. This was the reason that the query was not getting refreshed. 

 

I eventually deleted all these assosciations and just run the query again and it finally worked. 

 

Before doing that I had moved all the source files to a sharepoint folder. 

 

Thank you very much for your advice. 

Thanks for letting us know!





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

Top Solution Authors