Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Helper IV
Helper IV

How to Delete Old Data Set?



I am trying to delete an outdated data set in one of my workspaces. There are no assoicated reports, dashboards, or apps. However, when I attempt to delete, I'm getting the following message: "The dataset can't be deleted because it's included in the published app. Try again after unpublishing the app or updating the app after removing all related content."


Again, I don't have any apps!


Anyone know how to fix this?



Advocate II
Advocate II

I found a solution that did not involve unpublishing the app. Here is what worked for me:

  • Download the dataset.
  • Republish to the workspace.
  • Add the associated report to the app and "Update app."
  • Remove that same report from the app and "Update app."
  • In the workspace, navigate to the dataset and select Delete.
  • If a prompt comes up that says "At least one report outside of your workspace is using this dataset", still select Delete.
Not applicable

Hey Unpublish it first.Then restart the browser.And then Delete the dataset

Advocate III
Advocate III

Was having the same issue but figured it out.  


  1. Goto the workspace (also referred to the app)
  2. On top right click on eclipses (...)
  3. Select "Unpublish App"
  4. Now go to your dataset and delete and confirm
  5. Click on the workspace eclipses again
  6. Select Edit Workspace
  7. Publish app again
Not applicable

I am also facing same issue.Did you got any solution.

Hi SandyBL,


I was facing the same issue. Followed your steps exactly till Point 4. But unable to perform later steps. The workspace eclipses vanished. I dont see an option to "Publish app" again! 


How does this affect. What should I do to re enable it ? Please let me know.



Excelent solution!

Not applicable

This worked for me, but I wanted to offer a word of warning: Unpublishing the app will erase all your settings for that app, including access and navigation. You might want to screenshot or take note of your settings before you unpublish.

Thank you, Sandy. It worked. 

Tried to follow the outlined steps, clicked on eclipses (...)

but i don’t see the "Unpublish App", but i do see "Edit this Workspace".

As I found contradictory Info in the web: Do you lose any App-settings when you do the unpublish-republish cycle (user settings, subscriptions, shares...)



Not applicable

I tested this:

I have an app workspace that contains two datasets named dataset10 and dataset20.

Dataset10 connects to a Microsoft Azure SQL database.
Dataset20 connects to a Microsoft Excel file stored in Microsoft OneDrive for Business.

I create a report named Report10 that uses dataset10 and pinned Report10 to a dashboard named Dashboard10.


I published the app workspace to all the users in your organization.

Now I realised that I am not using dataset20 anywhere and I need to delete dataset20 from the app workspace.


What should I do first?
1-Unpublish the app.
2-Delete Dataset20
3-Edit Workspace
4-Publish App again

That worked, thanks!

Frequent Visitor

I'm experiencing the same issue. By clicking on "Manage Permissions," I can see where the dataset is in use, and for the datasets I'm attempting to delete, there is no related content. 

Microsoft Employee
Microsoft Employee

Hi @jl20,


If a dataset is part of one or more organization content packs, the only way to delete it is to remove it from the content packs where it's being used, wait for it to be processed, and then try deleting it again. Do you have some content packs related to this dataset? Click the gear on the top right and view content pack.


Is this dataset stored in your own workspace or App WorkSpace (group)? If it is in app workspace, will it be a group member publish app based on this dataset?


Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

This isnt resolved. He said he has no applications and I have the same issue. No applications, no content packs, but I cant delete the dataset and I get the same message.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.