Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate II
Advocate II

Deployment pipeline two way dependency between items

When we try to deploy from our dev workspace to our test workspace, we get the error "One or more items failed to deploy because it will result in a two way dependency between items."


Even when clearning the test workspace or attaching a new workspace as the test workspace, we still get the error. We've even tried completely remaking the pipeline, but no success. This happens no matter what we try to deploy, even if it's just a single empty report with a single manually entered number in the dataset, so to me it doesn't seem like it could be any of the contents.


I'd rather not recreate everything we've built in the development workspace in a new workspace. Has anyone else had this issue or does anyone know a potential cause/fix?

Frequent Visitor



I have the same error message when I try to deploy a lakehouse.

Is there any update for this issue?


Thank you!

Frequent Visitor

The writing's on the wall for fabric.  They get all excited about stupid 'short-cuts', but fail do deliver anything meaningful for building and managing ETL projects efficiently.  I'm actively looking at other alternatives at this point.

New Member

I like @AntSwig am still encountering this issue and would love a way of resolving it. When saving the data on power query in the datamart it loads perfectly, it is just when trying to deploy that it finds the circular dependancy. @Microsoft Please could you look into? 

Advocate II
Advocate II

Do Microsoft ever actually get around to helping with these or is it an excercise in futility posting here?

Regular Visitor

I'm also having this issue, also with a datamart that we built in test and need to move to prod.

Regular Visitor

Is there any fix to this yet?

Not really, but in my case it was a Analysis server source connection pointing to the same model (self connection) that when tried to run the deployment pipeline from Test to Prod failed with the 2 way dependency. 
Repointed that connection to Dev and worked just fine

Frequent Visitor

Looks like this is still a thing.  Curious to know if others determine its related to 'out of date'/incompatible measure definitions.

Not applicable

We are running into this issue as well. Sounds like Datamarts have quite a few bugs, probably why they haven't removed it from preview yet. 

Frequent Visitor



I am facing the same issue : 


Even deleting and recreating the datamart, we are not able to deploy from Dev to test.

Any suggestion?

I was able to resolve this problem for my team. I decided to recreate the model I was deploying all together. Since I use Tabular Editor 2, I can simply drag and paste measures over to the new model. This is where I think I encountered the culprit. One of my older measure objects was not a high enough compatibility level to be transferred over to the new model. So I think it comes down to how old your tabular object model is and if any of the measure objects in it are of a high enough compatibility to be "copied' into the target workspace. 


I'm not sure what "artifact" is referring to in the error message but I wish the Microsoft Power BI team would give a less vague answer to help resolve this easier. Obviously, recreating the model is not a preferred solution, and it would have been simpler if the error message just told me that one of my measures was old if that was the case for my problem.


Hope this helps!

Hi! Can you explain a bit how did you use Tabular Editor 2 to figure out the measure that was incompatible?



Not applicable

Anyone know the cause. Referring the issue to technical support isn't an answer.

I am having this issue now as well trying to deploy a datamart from dev to test.  It is not allowing me to move forward nor is there much information on the problem so I can fix it.


I appreciate any additional help or feedback.

Unfortunately no response/fix yet.

Not applicable

I'm also using datamarts. DataMarts are in preview, so I'm thinking that these are breaking the pipeline. Have you tried deleting your datamarts?

I am also using Datamarts, but it does say in the documentation that Datamarts are supported and I had previously been able to deploy them prior to getting this issue.


The problem is that the Datamart is the thing I am looking to make changes to and deploy most often, so having to delete these wouldn't solve my issues.

New Member

It's a major issue for me as well. I've even gone so far as to delete the objects in my Test workspace, and to completely replace two of the three objects I'm trying to push (two datamarts and a dataflow).

New Member

We are experiencing the exact same issue. Any ideas on what to check?

Frequent Visitor

I'm also having the same problem. I've been able to deploy between development and test before, but now I'm unable to deploy a simple custom date table from a dataflow. I'd love to know how to fix this too! 




Here is my error with ID's:


One or more items failed to deploy because it will result in a two way dependency between items.
Please check the technical details for more information. If you contact support, please provide these details.


  • Activity ID 96bcb410-af0e-4619-b977-3bab6a59f7a9
  • Request ID 8967d4b3-ca95-3557-cfed-34c8679b8f4f
  • Correlation ID 01efbcaf-357b-837e-d00f-0d67fc19eae2
  • Time Thu Apr 27 2023 13:13:39 GMT-0400 (Eastern Daylight Time)
  • Service version 13.0.20534.70
  • Client version 2304.3.13501-train
  • Cluster URI

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.