Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Frequent Visitor

Deployment Pipelines - Dataset is different after a "Successful" Promotion from DEV to TEST



We have been using Deployment Pipelines fairly successfully for 2 months now and working through issues. We need some ideas on how to best troubleshoot what is causing the dataset to be different, after a successful deployment from DEV to TEST. 


What we did:

1. Downloaded Power BI Desktop Oct 2020 version

2. Implemented RLS into our dataset

3. Published "Sales" PBIX file into Deployment Pipeline DEV workspace

4. Had an administrator "Take Over" dataset ownership from publisher developer, made sure credentials to our 1 data source was valid and refreshed dataset successfully

5. In Deployment Pipelines interface, Administrator selected "Sales" report and dataset from DEV and promoted to TEST workspace "Successfully", however after deployment, the dataset was not equivalent, but the report was. 

6. While troubleshooting, we had our BI "Sales" report developer rename the "Sales" report to "Sales_Test" and do the deployment of the report and dataset together from DEV to TEST, and the dataset was equivalent. 


We dont want the Developer doing the deployments, so do you have any troubleshooting ideas on why things are different?





We are not using any of the following Unsupported items:

Unsupported items

Deployment pipelines doesn't support the following items:

  • Datasets that do not originate from a .pbix

  • Reports based on unsupported datasets

  • Template app workspaces

  • Paginated reports

  • Dataflows

  • PUSH datasets

  • Workbooks






Not applicable

I just created dev and test workspaces and assigned them to deployment stages which had this exact problem. Deploying dataset made on TE did instantly alert difference. 


I waited for a while and redeployed, now it works. Could it be related to workspace configuration setupping which may take time. 

Advocate IV
Advocate IV

It has been two years since this thread was posted and I am experiencing the exact same issue with our deployment pipeline. We have successfully operated our dataset promotion for over a year without any issue ever. Suddenly since last week our TEST & PROD pipeline show our main dataset as "Different", even though they are identical as they always have been and have been successfully deployed from DEV to TEST to PROD.



Is there any progress on identifying possible causes?

Hi @Data-Rainer ,

Status of "Different" for a deployed item shouldn't be expected right after a successful deployment (could be though after a failed deployment). Therefore, it could be one of the two:

  • A bug - Please open a ticket and provide the deployment id (can be copied from the deployment's record on 'Deployment History')
  • A change was done next to the deployment completion. The dataset could be changed by several users on several places (not just through pipeline) so it could be someone else made a change.


In general, there could be several reasons for deployment pipeline to tag the "Different" label to an item, which can be ruoghly categorized as follow:

  1. Setting change: renaming an item, changing an item's sensitivity label.
  2. Code change: which means content/schema changes.
  3. Deployment rule was set and deployment is required to apply it - The rule will be considered for the compare action, but since deployment wasn't executed yet, a difference will be identified for the item. 

we're working these days on adding indication for 'Different' items, saying which of the above two reasoning categories is the reasone for the DIFF label. moreover, in case item got indication of code change, it would be possible for users to review the code changes (Read-only. Could be for only some item types at the begining).


Best regards,


Deployment pipeline PM

Not applicable

Hi there, 


I am facing the same problem recently as others, and to my knowledge, I think none of the things you mentioned addressed the issue. 

Exact same issue since this week, here too. 


A few tests that I have done : 

* Publish the dataset with a diferent name to force te creation of a new object, push to test --> says the files are different. 

* I recover versions from setembre and octobre that worked fine at the time, push to test --> keeps saying the are different.

* I started removing content from the dataset to check if it is any part of the dataset that is broken and even with a simple single table connected to the source it keeps saying the files are different. 

* When I test a new file with a dummy manual source it works fine. 


It seems to me a bug on the deployment pipelines ? 

Not applicable

Same here ... I agree ... it's very likely a system bug in the deployment pipeline. 

Thank you @LeeBenjamin ,


To the best of my knowledge, none of your possible explaination could be a cause in our case.
We have not made any changes to any settings of the dataset for the last couple of weeks, other than some role edits for row level security.

The deployment pipeline is always successful.
How do I log a support ticket please?


I am also having the same problem with the addition of the dataset not updating the schema changes.

I am having the exact same issue since the beginning of the week and would be super interested why this happening and how to resolve 



How to create a Power BI Support Ticket: 

  • If you are a Power BI Pro customer, support is included at no additional charge. Create a support ticket via GET SUPPORT
  • If you are an administrator of your Power BI tenant, open a support ticket in the admin center support portal.

After creating a ticket someone from Microsoft will contact you to get more details and investigate the issue. 




Microsoft Employee
Microsoft Employee

@apratt2003 , @Eliasaki92 , @perdigao18 ,
It could be a bug. Please open a ticket as described by @karo , so we could fix it ASAP.
Highly appreciated!


@apratt2003 , @Eliasaki92 , @perdigao18 , @Anonymous 

I have raised a support ticket with Microsoft.
I got the confirmation that it is a bug.
Microsoft is working on it.

ETA for a fix is MID January.

Thank you for investigating and the update.

Thank you. Can you share more details about the confirmation that it ? Will it be visible at the Known Issues ?


Thanks again !

Hi @perdigao18 and all,
As for now, this issue seems to be related to dataset having natural language Q&A. A fix for this issue will be release by MID january as @Data-Rainer mentioned.
However, in case of any doubt or concern, please contact support team that will know to say if this is the same issue or other. 
Best regards,



Any update on this bug? I have the same issue since beginning of December 2022.

Hello @sdrljaca and all,
The fix was just released to production a few days ago, so please try again.



I can confirm that the bug fix from Microsoft has worked for us. All our datasets show "equal" (not different) again after promoting them through the pipeline. Thanks @LeeBenjamin & the MS team for listening and fixing.

My pipes are finaly "clean" (there are now "Different" elements). Thank you 

Was the fix applied to gov sites?  I am still having the issue.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.