Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
GS-OIT
Helper I
Helper I

Dataflows not refreshing

I have a few dataflows set up which use API sources via Basic Auth. They were working fine 2 days ago but stopped this morning. I have checked and they load correctly in the query editor (in dataflows) and call the API but if I refresh them via the menu or schedule they simply do not start. I have downloaded the errors and it just says all entities failed to refresh.

 

Error: Internal error Request ID: 4ffed8b7-9429-cbd4-8056-b24b5852bcef Activity ID: 312445a0-1b37-4414-8210-3e9868b5686f

 

UPDATE: I have now added a flow which uses just an Azure SQL Table with the same result (can see the data in the editor but does not refresh on-demand or scheduled:

 

Error: Internal error Request ID: a924e5c9-2910-0f2c-fe7b-2d6af9f77596 Activity ID: 7a5c5f49-77ea-4e66-8953-298cc1af96fe

19 REPLIES 19
v-jiascu-msft
Employee
Employee

Hi @GS-OIT,

 

Can you share the complete error message, please? I tried to find it in the log database and I did find something. It seems you need to use a new authentication method. I would suggest you contact your administrator.

>>>AADSTS50076: Due to a configuration change made by your administrator, or because you moved to a new location, you must use multi-factor authentication to access 'f3b07414-****************41f3f4128'.

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The API based issues have the following error output.  I have the same code running successfully within a PBI dataset on the same group.

 

Run Time: Invalid date

Dataflow: ####### - Lookup Tables

Status: Failed

Entity: Boards

Start: 30/11/2018 17:05

End: 30/11/2018 17:05

Failed Error: Internal error Request ID: fc4ee9e1-0593-e23d-1f65-19117de875f6

Activity ID: f6056529-bf86-4f11-ba28-88a01d419e2e

Hi @GS-OIT,

 

Please check the settings of the Dataflow. What I can find is the credential error. 

Dataflows-not-refreshing1

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

This seems odd, I have a dataset that requires no connection and is purely generated by M code.  This is now coming back with a refresh error.  Could the authentication be something to do with Dataflows and Power BI validation rather than with the data source?

 

Start: 03/12/2018 08:52

End: 03/12/2018 08:52

Error: Internal error Request ID: 1ca7786b-7651-9957-31ff-87f107bfdaa9

Activity ID: f6b2450d-49d3-49bf-9677-9f9a93f46d51

 

Hi @GS-OIT,

 

I would suggest you create a new one from scratch. I only found this error. Please check it out or contact the administrator.

>>>Due to a configuration change made by your administrator, or because you moved to a new location, you must use multi-factor authentication to access 'f3b0741*************41f3f4128'.

BTW, did the error have something like below?

Dataflows-not-refreshing2

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It doesn't give me this information because in the Dataflows it just gives you a download of the errors which don't include the cluster information.  It does look like there's something to do with me having multi-factor authentication on my Azure AD and a restriction somewhere in an admin config that is stopping these dataflows refreshing ... but it's not clear from the errors or the message you have shared as to how I can resolve it. 

 

I created another one from scratch with the same issue.

 

I really apprecaite your help on this, I think dataflows are going to be awesome and they were working for a few days and then just stopped, I will take a look through our admin logs and see if I can see any changes.

How do I find out what the ID relates to that it's trying to use multi-factor authentication on?

Hi @GS-OIT,

 

The issue relates to refreshing. Can you still create a new one?

How does it look like in the settings of the Dataflow?

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I did this and it still didn't work. I have since change a new Azure AD policy which was recently applied. This makes it compulsory to have 2FA applied to administrator accounts. I removed myself from the policy and it is currently working.

 

I am going to try it for the rest of the day (checking it still works) and then re-apply the policy and see what happens as it does not take effect immediately.

 

I tried this because the message was also displayed following settings being applied to this area of Azure ADimage.pngimage.pngimage.png

Hi @GS-OIT,

 

I'm glad you found the cause. I'll appreciate it if you can share the final results.

 

Best Regards,
Dale

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I have the same error.

 

Error: Internal error Request ID: 42b2d3af-94a5-83df-86f2-b4d7224dbb5f Activity ID: 858536c7-a769-4a96-bfe2-6f1786e434eb

 

I also have 2FA enabled but unfortunately I can not disable it.

jason435,

 

Just to be clear, it was a policy where it was 'enforced' within Azure AD.  I changed it from being enforced for me but still had my 2FA enabled.  I have since reverted that setting and the issue has not re-occurred ... so either:

 

a) it resolved itself naturally (due to the authentication mentioned above being resolved)

b) the act of removing the enforcement and putting it back on solved the problem

c) changes that I am not aware of or that have been released since have resolved the problem.

 

Currently all dataflows are working still but I am not sure whether it was a co-incidence me changing settings or whether it changed anything.

 

Sorry, I cannot offer more insight but maybe worth checking the setting I mention in the Azure AD policy if you are an Administrator.

Thank you for the update. I wonder if that is the cause, I have other datasources, in datasets, using the same authentications method, and they work fine.

 

My dataflows are coming from excel files saved in onedrive for business. When I edit the entity, the preview refreshes no problem. If I edit the source, the data shown in query editor updates with refresh. However when I save and exit the editor, I can not refresh.

 

They were updating fine until early december they stoped. I wish the error message gave a little more insight.

 

 

After this working consistently since my last post, this morning it has suddenly failed again.  I have carried out the same actions (and I will see if it has any effect (over time).  Ironically it seems to be 14 days since the last issue, which fits in with the 2FA authentication issue.

 

@v-jiascu-msft Is there any way you can check to see what exactly is not being authenticated because I don't believe it's anything within the datasource, I believe there to be an authentication issue within the dataflow architecture which stops the refresh.  It stops within 3 seconds (for the whole job) and works fine if you go into it in the browser.

 

Most Recent Log:  

Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: 04e03947-a54c-48fc-906b-e53b58030501
Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: 28cf8040-79f4-4168-967f-1925a56f6b0f
Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: f1d1f306-a83b-4ec0-b1c8-8f039b6ff38a
Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: 80c2337f-8ae6-4ca6-8e6d-b95a9e6f3a58
Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: 095eef04-76b6-4f0a-8418-912bc9bb1808
Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: a597b472-3dd3-48b0-82f8-2362aed81536
Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: ffb32a05-60a8-4014-8f26-8f4f72a653ce
Error: Internal error Request ID: d0b77587-b2d4-f757-f93a-c9c2df579859 Activity ID: 9bf5edb7-a942-48e4-b0d1-087906f716dc

This is still an intermittent issue and I cannot figure out why it keeps failing (even with datasources that are purely M generated).  Any ideas?

Is there any further wisdom on this? I have checked and each time I open up the dataflow it works fine.  If I try to refresh it just shows this error with no detail.

 

I would love to transfer our business over to get the benefit from this but it just doesn't work at the moment.  As has been mentioned it might be authentication but it's not part of the credentials stored in the service as those work.  There must be some authentication between the Power BI service and one of the dependent items (i.e. Data Lake?  Processing? )

 

Error: Internal error Request ID: 8e87479c-5245-5589-27ba-c396319c03aa Activity ID: f431330d-28a9-43b7-a601-40ce20f6e5c4 Error: Internal error Request ID: 8e87479c-5245-5589-27ba-c396319c03aa Activity ID: e4bbe5aa-9e0b-4130-a0f0-44f67ffedca8 Error: Internal error Request ID: 8e87479c-5245-5589-27ba-c396319c03aa Activity ID: f6048c67-48b6-48fd-9a0a-be6154d86c2c Error: Internal error Request ID: 8e87479c-5245-5589-27ba-c396319c03aa Activity ID: d70fcec3-ad9d-41d7-8aa0-885ff7250dd5

Hi @GS-OIT,

 

I would suggest you create a support ticket here.

create-ATicket

 

 

Best Regards,

Community Support Team _ Dale
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Has this been resolved? We have been experiencing this very issues sine late Dec 2018. It is still a problem asof today.  I have confirmed that the identity used, mine, IS NOT enabled for MFA.


@Anonymous wrote:

Has this been resolved? We have been experiencing this very issues sine late Dec 2018. It is still a problem asof today.  I have confirmed that the identity used, mine, IS NOT enabled for MFA.


This seemed to resolve itself about a month ago (without intervention) but it is unclear what has changed.

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors