Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Reply
marduk20
Regular Visitor

Power BI error " Cube Table must have exactly one island"

Hi PBI community,

 

Has anyone of you already encountered this error " Cube Table must have exactly one island"?

 

Can you help further understand

2 ACCEPTED SOLUTIONS
MarkyMark1
Advocate I
Advocate I

I had the same issue. It resolved when I added new features in the preview features and restarted Power BI. I think it was Store semantic model using TMDL format and Enhanced publish dialogs features

View solution in original post

This issue has been fixed with the latest release of Desktop on March 4th (version 2.126.1261.0).

 

Thanks,

Farnoud

View solution in original post

30 REPLIES 30
farnoud
Employee
Employee

In order to diagnose the issue it would be helpful if anyone hitting this problem could collect and share their traces. The traces would include private information about your report, so you could DM me the zip file.

 

These are the steps in order to collect the traces:

1. Set the following environment variable PBI_forceTracing=1

farnoud_0-1708538558735.png

2. Open and refresh the report and wait for the issue to reproduce

3. Collect the diagnostics package: File -> Options and settings -> Options -> Diagnostics -> Collect diagnostics information -> Save (collect the entire PBIDesktopDiagnosticInfo.####.zip file)

 

Thanks,

Farnoud

This issue has been fixed with the latest release of Desktop on March 4th (version 2.126.1261.0).

 

Thanks,

Farnoud

Getting the error still in 2.127.1080.0 (64-bit)

I checked my issue version again, on the Version: 2.127.1327.0 64-bit (March 2024), this did not give the Island error.

Waiting on Farnoud (prob. different timezones).  Does anyone know how to access the requested, where should I look for setting "edit user variable" below:

J1298_0-1708589950167.png

 

yzc
Frequent Visitor

In windows search bar or control panel search bar, type and search "variables". Then go to "Edit environment variables for your account". There would be a window coming out, at the top you will see "User variables for xxx". Look down the user variables list, find the mentioned variable and edit. Hope it is clear enough.

Thank you,  was not looking at windows settings, was looking within PBI.

 

 

Samotana
Frequent Visitor

This has to do with februari 2024 release, I had november installed and when i tried it in November version I dont get the same issue. So for now if you revert back to a previous version this error do not occur!
November can be downloaded here :
https://learn.microsoft.com/en-us/power-bi/fundamentals/desktop-latest-update-archive?tabs=powerbi-d...

MarkyMark1
Advocate I
Advocate I

I had the same issue. It resolved when I added new features in the preview features and restarted Power BI. I think it was Store semantic model using TMDL format and Enhanced publish dialogs features

Thank you. I had enabled Enhanced publish dialogs. I disabled this, restarted Power BI then it worked.

I tried that but still have the same issue!

Here are the preview features I have enabled at the moment 

John_Wick_0-1708519509484.png

 

same issue remains for me on these settings too - incredibly frustrating, as we can't even rollback to old version without the headache of getting admin permissions to do so

In my scenario I was connecting to a published dataset (DirectQuery)

John_Wick_1-1708525162491.png

 

and that I am on the February 2024 build 

John_Wick_0-1708525048754.png

Ah - in my case I am connecting to 2 different PowerBI Datasets (or semantic models are they're now called), one of them is composite, the other is not. I guess it could pertain to the workspace of the non-composite. 

having said that - changing the connection location / workspaced for theses datasets have absolutely no bearing on this error. 

If you haven't tried it already, open a blank power bi or template and connect one of the semantic models and try publishing to your workspace. You can then try adding the second model to narrow down if that is causing the cube table.

thanks for your help - it fixed itself the following morning - no changes my end, very strange

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors
Top Kudoed Authors