Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
thomma
Frequent Visitor

Odata Business Central error

Hi All, 

 

I'm encountering an error trying to import Business central webservice tables using odata(see images). The error implies that my device settings don't match the data, but according to my windows settings my date format seems to be the same, data and device's settings are both in dutch date format. Does anyone know how to resolve this issue? All the other webservice tables which include date columns seem to be working fine. 

 

Thanks in advance!

thomma_1-1700751945586.png

 

thomma_0-1700751873609.png

 

 

1 ACCEPTED SOLUTION
v-cgao-msft
Community Support
Community Support

Hi @thomma ,

1. Check Regional Settings in Business Central and Verify Power BI Regional Settings. Make sure they match each other.

vcgaomsft_0-1701240868237.png

2. Clear All Permissions: If you still see an error, clear the Global Permissions for the OData service URI and try again. To clear Global Permissions, go to File > Options and Settings > Data Source Settings > Clear All Permissions.


3.Try importing a single record (30-06-23) with a date to see if the error persists. This can help isolate if the issue is with all date data or a specific entry.

4. Finally, consider using the standard date format yyyy-mm-dd as suggested in the message.

vcgaomsft_1-1701241589663.png

 

Best Regards,
Gao

Community Support Team

 

If there is any post helps, then please consider Accept it as the solution  to help the other members find it more quickly.
If I misunderstand your needs or you still have problems on it, please feel free to let us know. Thanks a lot!

How to get your questions answered quickly --  How to provide sample data in the Power BI Forum -- China Power BI User Group

View solution in original post

2 REPLIES 2
thomma
Frequent Visitor

Clearing permissions resolved the issue, thanks!

v-cgao-msft
Community Support
Community Support

Hi @thomma ,

1. Check Regional Settings in Business Central and Verify Power BI Regional Settings. Make sure they match each other.

vcgaomsft_0-1701240868237.png

2. Clear All Permissions: If you still see an error, clear the Global Permissions for the OData service URI and try again. To clear Global Permissions, go to File > Options and Settings > Data Source Settings > Clear All Permissions.


3.Try importing a single record (30-06-23) with a date to see if the error persists. This can help isolate if the issue is with all date data or a specific entry.

4. Finally, consider using the standard date format yyyy-mm-dd as suggested in the message.

vcgaomsft_1-1701241589663.png

 

Best Regards,
Gao

Community Support Team

 

If there is any post helps, then please consider Accept it as the solution  to help the other members find it more quickly.
If I misunderstand your needs or you still have problems on it, please feel free to let us know. Thanks a lot!

How to get your questions answered quickly --  How to provide sample data in the Power BI Forum -- China Power BI User Group

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors