Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
cassidy
Power Participant
Power Participant

"No Color" option missing in formatting

There use to be the option to select "No Color".  In some cases, there is an advantage to selecting No Color vs. White.

 

Any one know what happened to it or how to implement No Color?

 

cassidy_0-1673539807931.png

 

1 ACCEPTED SOLUTION
cassidy
Power Participant
Power Participant

I've found that somone called this issue nearly 2 Years ago via the Idea below.  Please vote for the Idea if you come across this post:

 

https://ideas.powerbi.com/ideas/idea/?ideaid=f4f23700-b785-eb11-8ced-281878dec3c7

View solution in original post

6 REPLIES 6
bklosowski
Frequent Visitor

This is ridiculous isn't it? Jesus Christ, this is a Microsoft product. More than 2 years that they know about this bug and no solution yet. 

Right? I so sick and tired of crappy microsoft products with no support and relying on users to find and make workarounds for all the bugs and stupid ideas.

Babette_Jolien
New Member

Hi Cassidy,

 

In case it is still relevant, you can try to reload a theme in which the color setting for this specific item in the visual is not set.

If you have a specific theme you need to use, try to edit it: 

  • save your current theme as a .json-file
  • open the theme-file and search for your visual name in the code
  • delete the color from the visual settings (this makes it 'no color')
  • save your new theme-file and reload it via 'browse for themes'

For example, write something like this: 

"pivotTable": { "*": {
      //...
     "subTotals": [{
          "rowSubtotals": false,
          "columnSubtotals": true,
          "fontColor": {"solid":{"color";"#846EAF"}},
          }]

Instead of this: 

"pivotTable": { "*": {
      //...
     "subTotals": [{
          "rowSubtotals": false,
          "columnSubtotals": true,
          "fontColor": {"solid":{"color";"#846EAF"}},
          "backColor": {"solid":{"color";"#E6E6E6"}}
          }]

 

1SonOfABeast
New Member

I have not found a direct solution.

But the workaround is to remove that column from your chart/matrix and then add it again. It seems to reset the specific column settings.

 

Hope this helps

cassidy
Power Participant
Power Participant

I've found that somone called this issue nearly 2 Years ago via the Idea below.  Please vote for the Idea if you come across this post:

 

https://ideas.powerbi.com/ideas/idea/?ideaid=f4f23700-b785-eb11-8ced-281878dec3c7

cassidy
Power Participant
Power Participant

An example of how it's actually necessary to be able to select "No Color":

 

I have Row Grand Totals selected to be Grey, however my Column on the Right has a Specific Column color of White.  But if you turn off apply to Totals so that it goes Grey, then I lose the ability to Center the Total value.  I either need the ability to Center Row Grand Totals or apply No Color to the Specific Column.

 

The only reason my column on the Left still works is because I never applied a Color to it, so it's still holding on to "No Color" thankfully.

cassidy_0-1673541301625.png

 

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.