Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
melpop
Helper I
Helper I

Stop Data Refresh

Hi,

 

I'm a PBI Premium User and have a very large dataset of approx. 500 million rows. The .pbix file is set up as a "Import" (for various reasons). As soon as I open the file, data starts refreshing, even though I don't change anything or even enter the Query Editor. I can see that the data is refreshing in my running requests in data warehouse, not PBI. How do I stop this from happening?

 

Hope that was clear 🙂

Thanks in advance!

 

 

 

1 ACCEPTED SOLUTION
v-yingjl
Community Support
Community Support

Hi @melpop ,

When you open Query Editor in power bi desktop, select the table that you do not want to refresh, right click it and disable Include in report refresh (it is active by default), close and apply Query Editor and the table will not refresh when the report is refreshed.

include in report refersh.png

Best Regards,

Yingjie Li

 

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

7 REPLIES 7
Josh_Boj
Helper I
Helper I

Did this ever get resolved?

space83
Helper IV
Helper IV

is that when we disable report refresh in power bi desktop it will reflect at power bi services once we publish the report?

v-yingjl
Community Support
Community Support

Hi @melpop ,

When you open Query Editor in power bi desktop, select the table that you do not want to refresh, right click it and disable Include in report refresh (it is active by default), close and apply Query Editor and the table will not refresh when the report is refreshed.

include in report refersh.png

Best Regards,

Yingjie Li

 

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

 

Anonymous
Not applicable

Does not work. Keeps refreshing after every single step 

 

Don't work, still refreshed with every change.

This doesn't work for me either, I have tables where the SQL connection won't work and therefore they are stopping my other tables from refreshing, when I deselect Include in report refresh, nothing changes.

RobertAFischer
New Member

There's an option for each query called 'Include in report refresh' which you could disable whilst working on the report, but you'd need to re-enable it before you publish the report. 

 

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors